Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A time ago I bought a new laptop but I had a lot of problems with it.

First there was the problem with ubuntu who hadn't a driver for the network card. After a long search I found the solution here: Wireless card Realtek RTL8723AE-BT is not recognized. The solution with the dropbox link worked, but not for long.

Not long after that I had problems with the card in windows AND ubuntu (and I still have them sometimes). Sometimes the card just does not work. I have looked for a solution and let people from the IT-service in our school look but nobody of us could find a solution.

After that, I upgraded the kernel of ubuntu, which has the next problem because the driver only supported until kernel 3.3. But in the same article that I've mentioned before, someone gave a second link for kernel 3.5. But from that time, everytime I restart my computer the driver isn't working automatically. I had to enable it as an LKM with modprobe.

It worked for a while, but suddenly it stopped working. It doesn't work anymore to use modprobe to enable it and I've tried restarting, reinstalling the drivers, ... I installed almost everythink I could think of and what I could find on the internet.

Do anyone have a solution for this? It's so irritating... Thanks!

EDIT: Now working again (for a time...)

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I#ve had similar problems. I usually rebuilt the drivers from the Realtek file "rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012" when updating to a new kernel manually, using the commands:

sudo su 
make clean 
make 
sudo make install 
sudo modprobe rtl8723e

With Kernel 3.2.0-38 this didn't work anymore. I got error:

Error inserting rtl8723e (/lib/modules/3.2.0-38-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723e/rtl8723e.ko): Invalid argument

In my case, uninstalling the "linux-backports-modules" (linux-backports-modules-cw-3.6-precise-generic) solved the poblem! :-)

Hope 4 you too!?

Greez from Germany,

Helmut

share|improve this answer
    
Thanks for your reply! Suddenly it worked again. I had found a newer version of the driver. The only problem was that it didn't start automatically anymore each time I rebooted. So I have solved it by loading the kernel module with /etc/modules. This helped me! Now it works most of the time! –  Olivier Van Bulck Feb 24 '13 at 15:19
    
Ok! Ir worked! I removed rtl8723 module from modprobe and disabled networking by doing sudo modprobe -r rtl8723e and restarted. It just worked! :X –  Sxs Oct 23 '13 at 8:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.