Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I connect my iPod and iPad to my computer to charge them. I do not want them to automatically mount on the desktop.

How can I keep using my computers many USB ports for charging without being bothered by auto-mounted devices?

share|improve this question
1  
As far as I'm aware, Ubuntu does not mount devices automatically, it just displays an icon which mounts the device when you click on the icon. So is it the icon which bothers you? –  Sergey Feb 10 '13 at 21:36
    
It is the icon, the “enter PIN on devices to mount” dialog, and the windows that open up that annoy me. –  Aeyoun Feb 11 '13 at 18:55
1  
Did you tried the to stop automounting via System Settings->Details->Removable Media ? –  serve.chilled Feb 13 '13 at 22:00
    
I treid that, serve.chilled. Did not work even when setting everything to not mounting. –  Aeyoun Feb 19 '13 at 14:31

2 Answers 2

Configuring Automounting

To enable or disable automount open a terminal and type dconf-editor followed by the [Enter] key.

Browse to org.gnome.desktop.media-handling.

The automount key controls whether to automatically mount media. If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.

There is another key org.gnome.desktop.media-handling.automount-open. This controls whether to automatically open a folder for automounted media.

If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead. This can be configured as shown below.

Taken directly from the ubuntu help page.

share|improve this answer

A good way to do that is perhaps to block device recognition in udev... Maybe with a rule like this (see this blog post)

SUBSYSTEM==”block” ATTRS{model}==”Apple device XXX ” OPTIONS==”ignore_device”

The con is that you won't be able to mount your device without removing the rule...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.