Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I loaded Ubuntu on to flashdrive. Now I want to remove it but when I try it returns Drive write protected. I have tried sudo dd if=/dev/zero of=/devsdb bs=512 count=1, but that returns Read only file system. I have tried many different USB format programs and all say the same. It does not have a switch on it! It is a 32gb CoreMicro USB flash drive. How do I remove Ubuntu from this USB drive?

share|improve this question
    
You said you used sudo dd if=/dev/zero of=/devsdb bs=512 count=1. Is that a typo in your question, or did you actually run that? (It should be sudo dd if=/dev/zero of=/dev/sdb bs=512 count=1 instead, with a / between dev and sdb.) Or was it something else? Also, when the device is plugged in, what's the ouput of df -h, mount, and file /dev/sdb? Please edit your question to provide all this information. –  Eliah Kagan Feb 10 '13 at 18:51

1 Answer 1

then you have really problem on that drive cause They are no chance to unlock it, my friend have this too and i tried everything on it but can't format or everything.

share|improve this answer
    
That is not an answer. –  guntbert Feb 10 '13 at 21:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.