Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Question: where to install the boot loader?

I have a system with 2 HDs, a 400GB and a 160GB.
My Ubuntu installation is on my 400GB HD and currently I have Windows on my 160GB. I'd like to install another clean linux distro (Mint) on my 160GB (i.e. remove Windows), but I'm confused as to where the boot loader goes. Obviously I don't want it to mess up my Ubuntu installation. At the installation window I'm given the following:

  /dev/sda1 ext4
  /dev/sda6 swap
  /dev/sda5 swap
  /dev/sdb1 ntfs

My question is, I have several options for boot loader installation . So where should I put it? Currently my system boots up and grub loads and gives me to option to choose between ubuntu (default) and optional windows.

My choices are

/dev/sda ATA ST.... (400.1GB)
/dev/sda1 Ubuntu
/dev/sdb ATA WDC.... (160.0GB)
/dev/sdb1 Windows 7 (loader)

What is the difference anyways? could anyone link where this is explained or explain it? Thank you all!

EDIT To be specific, I wanted windows completely gone. Just two Linux distros on separate HDs.

share|improve this question
up vote 1 down vote accepted

To get rid of such problem simply download super-boot-manager.

You will need to add the ppa:ingalex/super-boot-manager before. Open a terminal.

  • sudo add-apt-repository ppa:ingalex/super-boot-manager
  • sudo apt-get update
  • sudo apt-get install super-boot-manager

Once installed run the program, and select "Grub-manager", go under "Parameters", "Param. 1" and select the default OS to boot from.

share|improve this answer
thanks, that solves that – janjust Feb 13 '13 at 19:45

If you want to install it in the 160GB along with your Windows the bootloader should be installed in /dev/sdb

Now, if you have your 160GB HDD not already partitioned you need to make space for it. If you didnt when you installed your Windows then its taking all of the /dev/sdb space except for the 100MB boot partition at sdb1, and so Mint wont have a partition to be installed in, inside of /dev/sdb

The only thing left is, boot windows, administrative tools, get into disk management or something like that and try to "shrink" or reduce volume on your actual 160GB Windows partition to make space for Mint. Take in note the program itself will tell you that is recommended to defrag the partition first so you can maximize the shrink-able MB amount.

Once you reduce the Windows partition, let the rest as unallocated space and in the Mint install, your /dev/sdb should be looking like:

/dev/sdb1 - ~100MB - NTFS - Flags : boot (this is the place for bootloader) /dev/sdb2 - 160GB-shrinked - NTFS - Windows (windows partition= /dev/sdb3 - ShrinkedVolume(GB) - extended /dev/sdb4 - XGB - linux-swap (mint swap) /dev/sdb5 - RestofShrinked(GB) - ext4 - this is the / path partition (mint partition)

This is how it should look in the Mint installation, bootloader are always installed at first part of the disk. The rest is pretty common, you only need to reduce the Windows actual partition volume to make space for Mint and its own swap partition.

The bootloader job is giving the right directions for the OS to startup after the HDD has been called to boot by the BIOS. If you are trying to install the OS in the 2nd HDD then the bootloader will be located in the 2nd one (letting you choose Windows/Mint OSes). In the first HDD there is another bootloader for the time BIOS tries to boot from it (so it will give you few options even when only Ubuntu is installed, such as recovery, old kernels entries, memtest+..).

The choose of wich HDD startup first is up to your BIOS setup.

share|improve this answer
Hey, thanks for the answer! I completely removed Windows (I meant to do so). I really wanted to have Mint on the side. So I installed it on '/dev/sdb' I created a '\' mountpoint and a '\swap' on '\dev\sdb'. That's all fine I think, but I installed the bootloader on /dev/sda because in an earlier install I put it on '/dev/sdb' and grub didn't recognize it. I'm guessing I had to change something. Now I have Mint as the default selection and Ubuntu as an option. So I guess I did it "ok", except that I was hoping to have Ubuntu (default) and Mint (optional). – janjust Feb 11 '13 at 19:12
meeeh, just messed it all read my upper answer. – Toperharrier Feb 12 '13 at 23:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.