Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, this is kinda weirdo and not easy to explain. After the latest updates, I've noticed that my smartphone and other devices can't connect to the internet when my Ubuntu is running and connected via Wi-fi. After lots of testing (including changing my router) I discovered it's "Ubuntu's fault": other devices have access to the internet only when Wi-fi is off and when my laptop runs on my Windows 7 partition. Also, other devices can connect if W7 is connected via wifi. Obviously, when I try to connect a device being far from my laptop, the problem disappears... This problem started about 10 days ago and I still haven't found a solution. I've also did a fresh installation 3 days ago, hoping to resolve. My idea is that it may be an issue with the latest kernels.

Any help is more than well accepted :)

PS: Sorry for my english, I'm an italian guy

share|improve this question

I resolved the problem today :D

For some reason, the Broadcom proprietary driver of my wireless card, doesn't work properly causing the interference described above. If you have a Broadcom integrated wireless card in your laptop and you notice this issue (I've got an HP Pavilion DV6), launching Jockey from terminal typing


and disabling the proprietary driver, will do the trick. After that, be sure to reboot as suggested! Ubuntu integrated drivers will be used instead of the proprietary ones.

I hope it may be useful in the future :)

share|improve this answer
Help! this could be the solution for me too, but when i run "jockey-gtk" it says i have to load it with apt, when i load the packages and run the command again it will loop in this behaviour and say to download it – john Smith Dec 12 '13 at 23:13
wohoo got it from software center and it worked – john Smith Dec 13 '13 at 0:48
OMG ! I have been strugling with this issue. My friend's Ubuntu laptop was having the same issue. As soon as he connects to the network, other computers start to have connectivity issues. I removed the proprietory broadcom driver and restarted the system once. After that the issue is gone for good. Thank you so for the solution. You ROCK :-) – Abhay PS Feb 8 '14 at 21:26

Definitely a weird issue. I'm actually on Elementary OS Luna. This happened after a new installation. Also I was not able to lock sudo when I tried to apt-get update.

When I launched jockey-gtk (Additional Drivers) there was nothing to remove. I removed jockey-gtk from Synaptic and reinstalled and still no luck. I then booted from the live USB I used to install the OS and there was no interference with the clients connected to the WIFI modem -- because the live USB does not use proprietary drivers. While installing the OS there is an option to install 3rd party drivers in the wizard. I unchecked it and reinstalled the OS again and the issue was gone. So if the solution posted above doesn't work, reinstalling the OS without installing 3rd party drivers will do the trick. Hope this helps.

share|improve this answer

protected by Community Jul 13 '13 at 20:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.