Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unable to install Adobe Reader on my Ubuntu 12.10 Unity. I followed the directions here from www.noobslab.com

The first two commands did not throw any errors, but the last one went like this:

zach@zach-Lemur-Ultra:~$ sudo apt-get install acroread

Reading package lists... Done Building dependency tree        Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: acroread : Depends: ia32-libs (>= 20080808) but it is not going to be installed
           Depends: lib32gcc1 (>= 1:4.1.1) but it is not going to be installed
           Depends: lib32stdc++6 (>= 4.1.1) but it is not going to be installed
           Depends: lib32z1 (>= 1:1.1.4) but it is not going to be installed
           Depends: libc6-i386 (>= 2.3.2) but it is not going to be installed
           Depends: nspluginwrapper but it is not going to be installed
           Depends: acroread-common but it is not going to be installed
           Conflicts: adobereader-enu:i386 adobereader-enu:i386 : Depends: libgtk2.0-0:i386 (>= 2.4) but it is not going to be >installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a >solution).

If I try to install the dependencies by following the directions and running commands like

sudo apt-get -f install ia32-libs

I just get more list of other dependencies that need to be installed, with no end.

Is there an easy way?.

share|improve this question
    
The end of what you posted said to try just sudo apt-get -f install. Did you try that? –  Jack Feb 10 '13 at 15:24
    
I was trying so many different things, and I did not keep track. Eventually I gave up, and then somehow I noticed that the the program actually was installed, and it seems to work. I just wish I understood all those dependency messages. Thanks! –  zkurtz Feb 11 '13 at 4:30

2 Answers 2

The first package depends on the second which depends on the third, etc. But when you get to the (6,7,) 8th one (acroread-common), it is not going to be installed because it conflicts with adobereader-enu:i386. Just sudo apt-get -f install forces the install and ignores the conflict.

share|improve this answer

You should make sure the Medibuntu repositories are enabled. Most third party addons are disabled after upgrading from one Ubuntu release to another.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.