Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10. I have this error message that shows as a no-entry sign such as http://www.clker.com/clipart-no-entry-sign.html&h=300&w=294&sz=58&tbnid=C0ZjRlbghmq5iM%3a&tbnh=90&tbnw=88&zoom=1&usg=__C3EhezLXG0jHO9J44RNejKgwntk=&docid=2We-PKRvslJwZM&sa=X&ei=G7YXUa2oK4ro2gXPmYHYDw&ved=0CD4Q9QEwAw&dur=657">this.

I read the following questions on the forum:

Broken package after update: linux-headers, error brokencount >0

Dependencies not met on 12.04? duplicate

Broken package after update: linux-headers, error broken count >0

However, these point to my drive being full. I ran df -i and got the following output:

df -i
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/sda1            30048256  985142 29063114    4% /
udev                 1010270     511 1009759    1% /dev
tmpfs                1012523     445 1012078    1% /run
none                 1012523       1 1012522    1% /run/lock
none                 1012523       8 1012515    1% /run/shm

The error message also suggests that I run sudo apt-get install -f. I don't know what that does and when I run it, it warns me that it is going to remve about 2 GB worth of stuff!

sudo apt-get install -f
[sudo] password for dnaneet: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libgdl-3-common libaccess-bridge-java python-logilab-astng freetennis-common
  libntfs10 pylint sensible-mda cdparanoia libanjuta-3-0 python-sphinx
  python-mako python-pywapi texlive python-pygments libqtscript4-network id3v2
  python-reportlab libqtscript4-gui mercurial pyflakes libboost-signals1.46.1
  assaultcube-data texlive-fonts-recommended python-uniconvertor
  libtag-extras1 libqtscript4-sql python-renderpm libgtkpod1 libid3-3.8.3c2a
  k3b-data libqtscript4-xml procmail libqjson0 python-dnspython
  libjs-underscore libaccess-bridge-java-jni tipa libcluttergesture-0.0.2-0
  indicator-status-provider-emesene amarok-utils python-svn python-docutils
  libclutter-imcontext-0.1-0 python-rope cheese-common amarok-common
  texlive-fonts-recommended-doc anjuta-common wine1.2-gecko libmx-1.0-2
  vorbis-tools python-logilab-common python-markupsafe libgtksourceview2.0-0
  gtkpod-data libenet1a libqtscript4-uitools liblastfm0 libgsl0ldbl
  python-roman libloudmouth1-0 python-jinja2 libqtscript4-core python-xmpp
  libclutter-gtk-1.0-0 libgdl-3-1 libjs-sphinxdoc python-reportlab-accel
  libgtksourceview2.0-common mercurial-common
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  0ad 0ad-data 0ad-data-common amarok apturl banshee
  banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore
  bluez-gstreamer brasero brasero-cdrkit cb2bib cheese dconf-tools emesene
  empathy evolution-data-server gimp ginn gir1.2-rb-3.0 gir1.2-totem-1.0
  gir1.2-webkit-3.0 gloobus-preview gnome-codec-install gnome-control-center
  gnome-media gnome-online-accounts gnome-power-manager gnome-session-fallback
  gnome-shell gnome-tweak-tool gnome-user-guide gnome-video-effects gnuplot
  gnuplot-x11 gstreamer0.10-alsa gstreamer0.10-ffmpeg
  gstreamer0.10-fluendo-mp3 gstreamer0.10-gconf gstreamer0.10-nice
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse
  gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps
  gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly
  gstreamer0.10-pulseaudio gstreamer0.10-tools gstreamer0.10-x gtkpod gwibber
  indicator-datetime indicator-power inkscape k3b kde-runtime kdebase-runtime
  kdelibs5-plugins kdemultimedia-kio-plugins kile kile-l10n konsole
  kubuntu-debug-installer libbrasero-media3-1 libcanberra-gtk3-module
  libcheese-gtk20 libcheese1 libclutter-gst-1.0-0 libdmapsharing-3.0-2
  libgnome-media-profiles-3.0-0 libgoa-1.0-0 libgstfarsight0.10-0
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libk3b6
  libk3b6-extracodecs libkcddb4 libkdewebkit5 libokularcore1 libplasma3
  libpurple0 libqtwebkit-dev libqtwebkit4 libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-gnome libreoffice-gtk libreoffice-help-de
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-fr
  libreoffice-impress libreoffice-l10n-de libreoffice-l10n-en-gb
  libreoffice-l10n-en-za libreoffice-l10n-fr libreoffice-math
  libreoffice-style-human libreoffice-writer librhythmbox-core4 libslv2-9
  libsyncdaemon-1.0-1 libtelepathy-farsight0 libtotem0 libubuntuone-1.0-1
  libubuntuone1.0-cil libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwxgtk2.8-0
  libyelp0 metacity mythes-de mythes-de-ch mythes-en-au mythes-en-us mythes-fr
  nautilus-sendto-empathy nautilus-share netflix-desktop notify-osd okular
  oneconf openoffice.org-common phonon phonon-backend-gstreamer
  plasma-scriptengine-javascript playonlinux python-farsight python-gst0.10
  python-lxml python-papyon python-qt4 python-spyderlib
  python-ubuntuone-client python-ubuntuone-control-panel python-uno
  python-webkit python-wxgtk2.8 python-wxversion qapt-batch rhythmbox
  rhythmbox-plugin-cdrecorder rhythmbox-plugins screenlets screenlets-pack-all
  sessioninstaller shotwell software-center spyder steam:i386
  telepathy-butterfly telepathy-haze totem totem-mozilla totem-plugins
  ubuntu-docs ubuntu-sso-client ubuntuone-client ubuntuone-client-gnome
  ubuntuone-control-panel ubuntuone-control-panel-gtk ubuntuone-couch unity-2d
  update-notifier wine-browser-installer xul-ext-ubufox yelp zenity
0 upgraded, 0 newly installed, 172 to remove and 11 not upgraded.
10 not fully installed or removed.
After this operation, 2,001 MB disk space will be freed.
Do you want to continue [Y/n]?

So what should I do about this?

Edit: List of recent packages installed

2013-02-05 07:47:12 status installed man-db 2.6.0.2-2
2013-02-05 07:47:13 status installed bamfdaemon 0.2.104-0ubuntu1.1
2013-02-05 07:47:14 status installed desktop-file-utils 0.18-0ubuntu9
2013-02-05 07:47:14 status installed gnome-menus 3.2.0-0ubuntu2
2013-02-05 07:47:25 status installed hicolor-icon-theme 0.12-1ubuntu1
2013-02-05 07:47:26 status installed menu 2.1.45ubuntu1
2013-02-05 07:47:28 status installed initramfs-tools 0.99ubuntu8
2013-02-05 07:51:28 status installed google-chrome-stable 24.0.1312.68-r180326
2013-02-05 07:51:28 status installed ubuntu-docs 11.10.6
2013-02-05 07:51:28 status installed inkscape 0.48.2-0ubuntu1.1
2013-02-05 07:51:29 status installed libavutil-extra-51 4:0.7.6ubuntu0.11.10.3+medibuntu1
2013-02-05 07:51:29 status installed libavcodec-extra-53 4:0.7.6ubuntu0.11.10.3+medibuntu1
2013-02-05 07:51:29 status installed whois 5.0.11ubuntu3
2013-02-05 07:51:30 status installed mendeleydesktop 1.8-stable
2013-02-05 07:51:30 status installed chromium-codecs-ffmpeg 24.0.1312.56-0ubuntu0.11.10.1
2013-02-05 07:51:30 status installed chromium-browser 24.0.1312.56-0ubuntu0.11.10.1
2013-02-05 07:51:31 status installed chromium-browser-l10n 24.0.1312.56-0ubuntu0.11.10.1
2013-02-05 07:51:41 status installed menu 2.1.45ubuntu1
2013-02-05 07:51:42 status installed libc-bin 2.13-20ubuntu5.3
2013-02-05 07:51:42 status installed initramfs-tools 0.99ubuntu8
2013-02-09 12:46:24 startup archives install
2013-02-09 12:50:39 startup archives install
2013-02-09 12:50:47 install steam:i386 <none> 1.0.0.25
2013-02-09 12:50:49 status installed bamfdaemon 0.2.104-0ubuntu1.1
2013-02-09 12:50:50 status installed desktop-file-utils 0.18-0ubuntu9
2013-02-09 12:50:50 status installed gnome-menus 3.2.0-0ubuntu2
2013-02-09 12:51:04 status installed hicolor-icon-theme 0.12-1ubuntu1
2013-02-09 12:51:05 status installed man-db 2.6.0.2-2

Output from sudo apt-get install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 steam:i386 : Depends: xterm:i386 but it is not installed or
                       gnome-terminal:i386 but it is not installed
              Depends: zenity:i386 but it is not installed
E: Unmet dependencies. Try using -f
share|improve this question
    
Can you provide the list of some RECENT packages that you have installed? –  smartboyhw Feb 10 '13 at 15:12
    
@smartboyhw edit made. –  drN Feb 10 '13 at 15:17
    
actually this looks like the list of the recent repositories enabled instead of the latest packages you installed. Try run cat /var/log/dpkg.log | grep "\ install\ and paste the output here. –  smartboyhw Feb 10 '13 at 15:20
    
@smartboyhw cat /var/log/dpkg.log | grep "\ install` just gives me a prompt >` because of the backslash and no output without `` –  drN Feb 10 '13 at 15:25
    
try cat /var/log/dpkg.log | grep "\ install\ " again.... –  smartboyhw Feb 10 '13 at 15:27

1 Answer 1

up vote 2 down vote accepted

drN: The steam client is only supported in 12.04 or up, it is NOT supported in 11.10. So please remove the package steam by typing sudo apt-get remove steam.

share|improve this answer
1  
Thanks! I'm glad one of us thought of that! :P –  drN Feb 10 '13 at 15:48
    
@drN if you can mark it as answer and upvote it:) –  smartboyhw Feb 10 '13 at 15:48
1  
I'm just ridding my computer of the steam client. Once I have that done and perhaps restarted, I'll check for the error status and then mark it as an answer! :) –  drN Feb 10 '13 at 15:49
1  
solved! Did not need a restart! –  drN Feb 10 '13 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.