Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated Ubuntu 12.04 yesterday (09/01/2013).

After the update (updated the kernel, and several other things that I noticed), it's requested a system reboot.

Rebooted: Unity 3D is loaded (only the vertical bar), the "Unity background is purple" and nothing else is loaded icons, top bar, etc. (CTRL+ALT+F1 doesn't work, it's completed freeze).

Only works the Unity 2D or XFCE.

EDIT:

➜  ~  sudo glxspheres 
Polygons in scene: 62464
Visual ID of window: 0xa6
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Sandybridge Mobile 
60.171477 frames/sec - 67.151368 Mpixels/sec
60.013886 frames/sec - 66.975496 Mpixels/sec
59.871287 frames/sec - 66.816357 Mpixels/sec
➜  ~  sudo optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 540M/PCIe/SSE2
94.500831 frames/sec - 105.462928 Mpixels/sec
96.664706 frames/sec - 107.877811 Mpixels/sec
96.986230 frames/sec - 108.236633 Mpixels/sec
107.303790 frames/sec - 119.751029 Mpixels/sec
➜  ~  

OS: Ubuntu 12.04 x64
Notebook: DELL XPS L502X
Graphic Card: Nvidia GT540m 2gb

Sorry about my english.

share|improve this question

1 Answer 1

Nice rig! It would a shame to use in 2D mode. Few things to try:

  1. Boot with an older kernel. Easy to do if you have ever updated your kernel - just choose "Previous Linux versions" in the Grub menu and then choose any of those listed. What you see there are older kernel versions that still exist in your system.
  2. If you are using proprietary graphics driver, remove and see whether it changes anything. Use Additional driver/jockey to do that. Idea is to test whether it is a driver issue or something else.
  3. Try some apt-get commands to see if it reports any error. Something like(updates packages index and then installs available updates with required dependencies):

sudo apt-get update && sudo apt-get dist-upgrade

Even if no error is reported it might fix your problem.

PS! Sorry for the late follow-up.

share|improve this answer
    
I dont know how boot with other kernel version. Obs.: I'm not a jedi user of Ubuntu, just medium-advanced user (a developer). –  Patrick Maciel Feb 10 '13 at 14:33
    
Hold down Shift at boot to display GRUB with kernel options. Best to fresh install while backing up home in my opinion. Upgrading always breaks something... –  fleamour Feb 19 '13 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.