Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some issue with internet access. I've got a Samsung laptop with a Broadcom wireless card and Ubuntu 12.04 on it. Everything worked fine at the beginning, but recently, probably after some kernel update, I noticed that I don't receive any packets for few seconds. When I tried to look what's wrong I noticed I can't access to router (some cheap TP Link), even ping is failing. Router is ok, because I am able to access it from other devices, and even from my laptop from Windows. But this disconnecting is very annoying. Anyone has the same issue? Where can be the problem?

03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    Subsystem: Wistron NeWeb Corp. Device 051a
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fc500000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Vendor Specific Information: Len=78 <?>
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-b1-ff-ff-ef-00-1b
    Capabilities: [16c] Power Budgeting <?>
    Kernel driver in use: wl
    Kernel modules: wl, bcma, brcmsmac
share|improve this question
    
What encryption (if any) are you using to connect to the router? Also, please run the command lspci -v in a terminal and add the last section, which will say Network Controller at the top, to your question. –  Aaron Feb 10 '13 at 13:36
    
@Aaron I use only WEP. Problem is, I can access the Internet. Furthermore, when I use nmap to scan devices in LAN, it shows them properly, with router exception (because it acts as a gateway?). I'm updating question with lspci -v output. –  kubuscmg Feb 10 '13 at 14:29
    
It seems that this problem has been encountered(and solved) before. Try the solution posted at askubuntu.com/questions/250858/… –  Aaron Feb 10 '13 at 14:34
    
Thanks, I'll try this. –  kubuscmg Feb 10 '13 at 14:41
    
Thanks, @Aaron, it works! –  kubuscmg Feb 10 '13 at 15:15
add comment

marked as duplicate by Eliah Kagan, hhlp, Seth, Mik, Chris Wilson Feb 10 '13 at 19:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.