Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Bluetooth 4.99 & bluez.

My audio device is paired successfully. However, on the second attempt to connect there is no auto pairing. I have to issue:

bluez-test-audio connect <address>

each and every time to reconnect.

All values for adapter annd device are correct in /var/lib/bluetooth.

Spent hours/days on this! Help please!


added:

root@debian:~# dir /var/lib/bluetooth/00:1B:10:00:05:94 classes did features lastused manufacturers profiles trusts config eir lastseen linkkeys names sdp


edit: I enabled Autoconnect in audio.conf - makes no difference ... or should I delete the whole bluetooth settings, and restart the pairing again?

I'd really appreciate some help on this.

share|improve this question
    
Can you add the contents of /var/lib/bluetooth to your question? –  Aaron Hill Feb 10 '13 at 13:33
    
Here's what's in /var/lib/bluetooth for the specific adapter: –  castalla Feb 10 '13 at 14:55
    
oops - added above –  castalla Feb 10 '13 at 15:01

1 Answer 1

Try this, add:

Disable = Media

into "General" section of /etc/bluetooth/audio.conf

with this my bluetooth headsets connect/reconnect again without problem.

It's not from my head, I found a hint in one post on spanish raspberry pi forum.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.