Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just obtained an ASUS RT-N66U router, which I've flashed with the Tomato firmware. The router is for the most part working fine, but I'm having trouble connecting to Facebook in a consistent way. There's a Macbook Air on the network that always seems to be able to connect, but my Ubuntu laptop can only connect through a VPN.

This seems to me a DNS problem, but a weird one, as it doesn't affect all machines on the network, or all sites, for that matter. I've tried things like changing the DNS server addresses on the router (to Google's and OpenDNS's) and also tried to turn off Ubuntu's local dnsmasq by commenting out

dns=dnsmasq

in /etc/NetworkManager/NetworkManager.conf, but without success. I'm not sure what can I try next as I've never had a DNS issue where only one site seems to fail (although twitter seems to be awfully slow without the VPN as well).

Any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ok, so after researching this a bit, I found:

Ubuntu 12, chromium/chrome facebook not loading

and

How to diagnose a selective DNS resolution failure?

and indeed, I switched the 'MTU' setting for my wireless interface from to 1492 and voilá, problem fixed. Now the why is another issue completely.

share|improve this answer
    
Can you accept your own answer? –  jdthood Feb 11 '13 at 8:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.