Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Good afternoon, I am a new Ubuntu user and I need some help to duly set up my GPU card. I am really lost with this, I have read a lot about how to configure Nvidia cards, but I cannot possibly solve a matter related to Compiz, Nvidia, the benchmark tool glxgears (Well, most of linux users claim it is not a real benckmark tool) and games performance on fullscreen. So I just hope someone could please help me to set it up.

Here, how some files are configured (only resumed):

  • Xorg.conf:
Section "Monitor"
  Identifier     "Monitor0"
  VendorName     "Unknown"
  ModelName      "Unknown"
  HorizSync       28.0 - 33.0
  VertRefresh     43.0 - 72.0
  Option         "DPMS" 
EndSection

Section "Device"
  Identifier     "Device0"
  Driver         "nvidia"
  VendorName     "NVIDIA Corporation"
  Boardname      "GeForce 8400M GS"
  Option         "NoLogo"                 "True"
  Option         "NoFlip"                 "False"
  Option         "RenderAccel"            "True"
  Option         "AddARGBLXVisuals"       "True"
  Option         "AllowGLXWithComposite"  "True"
  Option         "DynamicTwinView"        "False"
  Option         "TripleBuffer"           "True"
  Option         "TwinView"               "False"
  Option         "FlatPanelProperties"    "Scaling = Native"
  Option         "RegistryDwords"         "PerfLevelSrc=0x2222; PowerMizerEnable=0x1; PowerMizerLevel=0x3; PowerMizerLevelAC=0x1"
EndSection

Section "Extensions"
  Option         "Composite"      "Enable" 
EndSection

Section "Screen"
  Identifier     "Screen0"
  Device         "Device0"
  Monitor        "Monitor0"
  DefaultDepth    24
  SubSection     "Display"
      Depth       24
  EndSubSection 
EndSection
  • nvidia-sttings:
# Attributes:

AS5720G:0.0/SyncToVBlank=1
AS5720G:0.0/LogAniso=0 
AS5720G:0.0/FSAA=0 
AS5720G:0.0/TextureSharpen=0
AS5720G:0.0/TextureClamping=0 
AS5720G:0.0/AllowFlipping=1
AS5720G:0.0/FSAAAppControlled=1 
AS5720G:0.0/LogAnisoAppControlled=1
AS5720G:0.0/OpenGLImageSettings=3 
AS5720G:0.0/FSAAAppEnhanced=0
AS5720G:0.0/DigitalVibrance[DFP-0]=0
AS5720G:0.0/GPUScaling[DFP-0]=65538 
AS5720G:0.0/ColorSpace[DFP-0]=0
AS5720G:0.0/ColorRange[DFP-0]=0 
AS5720G:0.0/XVideoTextureBrightness=0
AS5720G:0.0/XVideoTextureContrast=0 
AS5720G:0.0/XVideoTextureHue=0
AS5720G:0.0/XVideoTextureSaturation=0
AS5720G:0.0/XVideoTextureSyncToVBlank=1
AS5720G:0.0/XVideoSyncToDisplay=65536
  • CompizConfg - Unity profile:
[composite]
s0_slow_animations_key = Disabled
s0_detect_refresh_rate = true
s0_refresh_rate = 60
s0_unredirect_fullscreen_windows = true
s0_unredirect_match = (any) & !(class=Totem) & !(class=MPlayer) & !(class=Vlc) & >     !(class=Plugin-container) & !(class=Firefox)
s0_force_independent_output_painting = false

[opengl]
s0_texture_filter = 1
s0_lighting = false
s0_sync_to_vblank = true
s0_texture_compression = false
s0_unredirect_driver_blacklist = (nouveau|Intel).*Mesa (8.0|9.0)

Here, some system details:

OS: Ubuntu 12.04.1 LTS, Unity 3D
Kernel: 3.2.0.37
CPU: Intel Core2Duo T7100
GPU: Nvidia Geforce 8400M GS

And here, the glxgears issue:

1) - With all above changes currently set, glxgears is limited to refresh rate (about 60 frames per second) both windowed and fullscreen modes, but gears move kind of like laggy and sluggish.

2) - If 'Sync to vblank' is disabled in CCSM, glxgears is limited to refresh rate both windowed and fullscreen mode. Gears are smooth and flawless, but there is a bit of tearing on fullscreen, just in the middle.

3) - If 'Sync to vblank' is disabled in OpenGL Nvidia-Settings, glxgears is not limited to refresh rate neither windowed nor fullscreen (between 180 - 200 fps). Gears move perfectly smooth, flawless and without tearing when they are windowed, but they are laggy and sluggish on fullscreen (I guess due to the composite. The refresh rate is 200 fps or 1000 frames per 5 seconds).

4) - If 'Sync to vblank' is disabled in both CCSM and OpenGL Nvidia-Settings, glxgears is not limited to refresh rate (between 2050 - 180 fps). Gears move smooth but with tearing.

Most of Nvidia & Ubuntu users suggest turning on both 'Sync to vblank' and overlook the glxgears performance, but I do not know if I should do it or not.

Lastly, regarding fullscreen games, I checked 'Sync to vblank' from CCSM does not affect their performance, but OpenGL 'Sync to vblank' form Nvidia-Settings does. Games have some tearing issues and they are not smooth at all, even though frames are limited to 60fps. I am really looking forward to getting rid of that tearing.

Thanks in advance.

share|improve this question
    
Just to complement your very well detailed question. Yes, many say glxgears is not a benchmark tool, but for testing performance I always use it because A) it gives me an idea of how games will perform. If it has shows low FPS, games will show low FPS, if it shows high, games will be OK. And B), The benchmark part is because it does not test many OpenGL or similar features, video cards have, but only goes to test a handful of them, even if this is true, one can see how changing drivers (with Nvidia/Ati for example), changes FPS in glxgears (Which is a good or bad thing). –  Luis Alvarado Feb 9 '13 at 16:13
add comment

1 Answer 1

Change the anti-aliasing and anisotropic features to "Override Application settings".

share|improve this answer
2  
There is no deleted answer here. I can see deleted answers. –  hbdgaf Feb 23 '13 at 22:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.