Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Ubuntu version from 10.10 to 11.04 alpha and on reboot got an error "The disk drive for / is not ready yet or not present Continue to wait; or Press S to skip mounting or M for manual recovery.

When I press M I get the normal command prompt, how do I get the correct drive mounted??

share|improve this question
2  
Please see this thread and file a bug: meta.askubuntu.com/questions/871/… –  Jorge Castro Feb 8 '11 at 17:54
    
same problem jacked fstab and mtab with old style device layout no success date 2.22.2011 if fix was in I didnt get it with online update! –  user11295 Feb 22 '11 at 20:25
    
Just had the same problem on my laptop. Did an upgrade from 10.10 to 11.04 yesterday. All went smoothly, rebooted a few times all ok. Decided to install more updates today, reboot and now getting the same error message. I booted via PartedMagic and my fstab is using UUID. Am able to mount the drive without any problems in PartedMagic. It contains # out entries for the old format of /dev/sda1 etc. Changing to /dev/sd made no difference. –  user13650 Apr 5 '11 at 13:21
    
Well I've now used the Live CD to perform an upgrade, all went through OK. Reboot, same error! –  user13650 Apr 5 '11 at 15:33
add comment

3 Answers 3

First guess is that there is an incorrect entry in /etc/fstab. Another possibility (hope not) is that something is wrong with one or more partitions or the drive / controller.

Suggestions:
-boot from liveCD/liveUSB and check integrity of partitions (using gparted for example)
-mount your root partition and take a look at /etc/fstab for anything wrong (you might try using /dev/sd? instead of UUID?)
-worst case scenario, there is a repair install option from the liveCD/liveUSB

share|improve this answer
add comment

You should restart the update manager again. There was an update that was justed released for that not to long ago.

share|improve this answer
add comment

protected by Community Aug 29 '11 at 2:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?