Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a file /usr/share/X11/xorg.conf.d/90-keyboard.conf containing

Section "InputClass"
        Identifier      "Defaults"
        MatchIsKeyboard "true"
        Option          "XkbOptions"    "ctrl:nocaps,compose:menu,terminate:ctrl_alt_bksp"
EndSection

It looks like it's getting picked up; in /var/log/Xorg.0.log it says

[  3772.382] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[  3772.382] (**) Option "xkb_rules" "evdev"
[  3772.382] (**) Option "xkb_model" "pc104"
[  3772.382] (**) Option "xkb_options" "ctrl:nocaps,compose:menu,terminate:ctrl_alt_bksp"

But it has no apparent effect; caps lock is still caps lock. Am I missing something obvious?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.