Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two analog TV tuners. Both use the chip SAA7130: "kworld pci plus tv" and "ENCORE FMLTV-FM"

They worked ok in 10.04 "out of the box" and now i want to update to a new Ubuntu and I can't get them to work in 12.10.

they are correctly reconized in "dmesg" with their name and model, and registered as video0 and video1

TVTIME: I can find just 2/3 channels, but with poor quality.

I think the card is recognized but the tuner=XX is not correct... I think this is due to Ubuntu changed v4l1 to v4l2. Can i come back to v4l1? Perhaps i can manually change the "tuner=XX" to a correct one?

Then there is another problem: When i try to use tvtime with a specific card tvtime --device /dev/video0 (or video1) i get cannot open capture device /dev/video0.
Then I tried mythtv and when i want to put a card it just said failed to open.

So i don t know what to think, it seems that there is a privilege problem? (I tried running as root, adding my user to group video, etc... no luck)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.