Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, so I recently installed Ubuntu on an old laptop and now it won't connect to the internet. When I plug in the Ethernet cord is says connecting and the little icon things moves but after a minute or so it says disconnected and repeats.

Before I installed Ubuntu it worked fine using Win XP so it's not the port or anything and besides, it recognizes the cord is there, it just won't fully connect. I don't have wireless so I;m not sure if that works or not but I can view the networks around my place. Any ideas? I really need to get this working. Thanks.

TL;DR LAN says connecting and then says disconnected.

share|improve this question
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Feb 8 '13 at 15:29

start the terminal and type

gksu gedit /etc/network/interfaces

File will opened in gedit. It will be empty or should contain

auto lo
iface lo inet loopback

In gedit add following lines and save it and close

auto eth0
iface eth0 inet dhcp

and restart the network manager: sudo service network-manager restart It works fine with my case

share|improve this answer

Try the following:

sudo restart network-manager

Also: a little bit more information of your system would be helpful!

share|improve this answer
@user129523: So, did you then successfully restart your network manager by using the command I provided? – nikercan Feb 9 '13 at 9:34
Yeah, I tried the command but it didn't help. I'm still not able to connect. – Perry Bezenar Feb 9 '13 at 19:43
Also is there a way I can Update Ubuntu without connection to the internet? Like Update it with a thumbdrive or something? I mainly just want the plugins and stuff to play media such as music and video. – Perry Bezenar Feb 9 '13 at 19:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.