Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've an NTFS partition shared with Windows 8 and Ubuntu which is mounted automatically using fstab as /mnt/General. I've copied some data to the partition using Widnows, and then copied some more data using Ubuntu. When I looked at the owner of the partition and it's sub-directories and files, I found that the owner is root, so I ran chown -Rv on /mnt/General to make my self the owner of the partition and it's sub-directories and files. After that I booted Windows and read the partition, when I booted Ubuntu again I found that the /mnt/General is an empty folder when viewed from the file browser; I then used ls in the terminal to view files and it views the following line:

    ls: cannot access General/$RECYCLE.BIN: Input/output error

and then it view some of the files and directories but they where missing some files, after that I booted Windows again and I discovered that I have no write permission on Windows. How do I fix that?

I don't know if that is relevant, but I'm using UEFI Secure Booting to boot both Ubuntu and Windows.

Note: The data on the NTFS partition is all backed up, so a solution that involves formatting the partition is acceptable, although I'd prefer not to do that.

share|improve this question
    
Tried to change permission to rwx for all, but when I ran ls -l, I found that the permission didn't change, it;s still drwx------ –  Sameh Hany Feb 8 '13 at 13:40
    
I finally solved it by changing permission from Windows, but I'm wondering if there is a way to do it from Linux? –  Sameh Hany Feb 8 '13 at 14:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.