Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I found .deb files in my cache for some webapps I installed. Then I used apt-get to install some other web apps. But the icons aren't showing up on the unity bar. How do I rectify this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

After you install a WebApp, it doesn't get added to your Unity Launcher like normal applications do. You actually have to visit the website in your browser and enabled/install it on that website. When you visit a website supported by or supports WebApps, you should get a little option bar or panel that asks you if you want to install or enable WebApps for that website. Once you click yes, you should see the icon appear in your Unity launcher and Dash. If you don't get an option bar/panel then most likely you have the website blacklisted.

Remove an “excluded” WebApp website in Firefox:

  1. Go to Edit – Preferences – General
  2. Under “Desktop Integration” click the Exceptions button
  3. Make sure the website you are trying to use is removed from that list.
  4. Restart your browser and revisit the website.

Note, by default, Firefox is the only browser that supports Unity WebApps; however, you can install an extension to allow Chromium to work as well. I believe the package name is: unity-chromium-extension.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.