Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm very new to Ubuntu and I messed up something and I cannot install any packages with apt-get install.

Initially I got this error:

The following packages have unmet dependencies:
 linux-image-server : Depends: linux-image-3.2.0-36-generic but it is not going to be installed
 linux-server : Depends: linux-headers-server (= 3.2.0.36.43) but 3.2.0.37.45 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And when I tried to run "sudo apt-get -f install" I get this:

dpkg: dependency problems prevent configuration of linux-image-server:
 linux-image-server depends on linux-image-3.2.0-36-generic; however:
  Package linux-image-3.2.0-36-generic is not installed.
dpkg: error processing linux-image-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of linux-server:
 linux-server depends on linux-image-server (= 3.2.0.36.43); however:
  Package linux-image-server is not configured yet.
 linux-server depends on linux-headers-server (= 3.2.0.36.43); however:
  Version of linux-headers-server on system is 3.2.0.37.45.
dpkg: error processing linux-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 linux-image-server
 linux-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help is much appreciated because I don't know what to do next.

share|improve this question

marked as duplicate by Seth, Eliah Kagan, Nathan Osman, Rinzwind, Javier Rivera Feb 13 '13 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Related: APT wedged by kernel version mismatch –  Eliah Kagan Feb 10 '13 at 20:20

1 Answer 1

The way I fixed this was to manually install a newer version of the linux-server package as such:

wget https://launchpad.net/ubuntu/+archive/primary/+files/linux-server_3.2.0.37.45_amd64.deb
sudo dpkg -i linux-server_3.2.0.37.45_amd64.deb 

If you're running a 32-bit system you'll need a slightly different URL and package name that you can find here.

Thanks to @Eliah Kagan for his answer here http://askubuntu.com/a/253581/79271 and help with question-meta-issues.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.