Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Lubuntu 12.04

I accidentally set the keyboard to the wrong language when I was installing the system, and now I have to change that keyboard setting every time i start the computer.

How do I change the default keyboard language in Lubuntu 12.04?

share|improve this question
1  
preferences->lxkeymap->select the language. click apply. –  Hermann Ingjaldsson Feb 8 '13 at 10:19
    
(at)lxpanel --profile (at)xscreensaver -no-splash (at)xfce4-power-manager (at)pcmanfm --desktop --profile lubuntu (at)/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 –  Hermann Ingjaldsson Feb 8 '13 at 10:45
    
i replaced the at symbol with (at) due to some website setting problem. –  Hermann Ingjaldsson Feb 8 '13 at 10:45
    
and setback query returns: rules: evdev model: pc105 layout: us –  Hermann Ingjaldsson Feb 8 '13 at 10:46
    
I want US, but the computer keeps starting up with Icelandic because that's what I clicked when installing. –  Hermann Ingjaldsson Feb 8 '13 at 10:49
show 1 more comment

3 Answers 3

To make a permanent change of the language of the keyboard, write this in the terminal:

 echo '@setxkbmap -option grp:alt_shift_toggle "es, us"' | sudo tee -a /etc/xdg/lxsession/Lubuntu/autostart

This sets the keyboard language to Spanish. This works for Lubuntu 12.04 too.

To just change the keyboard layout for the session, write this in the terminal (this example is for the english language):

setxkbmap -layout us
share|improve this answer
add comment
up vote 0 down vote accepted

Running the following in the Terminal will change the keyboard setting to US for example:

setxkbmap -layout us

And then you can make bash aliases such as keybaord_layout us, etc.

share|improve this answer
add comment

I have faced the same problem. After instalation of Lubuntu, keybord layout became US. The following command helpd me to change it back to UK. Thanks for those who started this thread.

setxkbmap -layout gb
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.