Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I removed the previous version of Libreoffice and installed the current Libreoffice 4.0 from But now the icons and global-menubar are inactive: see screenshot.

Click on the image to open a full-resolution version.

After the first time, I removed Libreoffice 4.0, and restarted, then installed it manually again. The script below is what I used both times.

sudo apt-get -y remove libreoffice*

cd /tmp
tar -xvf LibreOffice_4.0.0_Linux_x86-64_deb.tar.gz
cd LibreOffice_4.0.0.3_Linux_x86-64_deb/DEBS
sudo dpkg -i *.deb
cd desktop-integration
sudo dpkg -i *.deb

cd /tmp

tar -xvf LibreOffice_4.0.0_Linux_x86-64_deb_langpack_nl.tar.gz
cd LibreOffice_4.0.0.3_Linux_x86-64_deb_langpack_nl/DEBS
sudo dpkg -i *.deb

cd /tmp
tar -xvf LibreOffice_4.0.0_Linux_x86-64_deb_helppack_nl.tar.gz
cd LibreOffice_4.0.0.3_Linux_x86-64_deb_helppack_nl/DEBS
sudo dpkg -i *.deb

Question: How do I get the standard icons back?

share|improve this question
up vote 6 down vote accepted

I think you've got LibreOffice's high contrast icons which happens if LibreOffice doesn't like something about your gtk theme. You can for check that in Tools > Options > View. Note the image below is from LibreOffice 3.6 and not 4.0:

LibO's icons

Here are two links that indicate what Unity integration is required:

share|improve this answer
you perhaps can give a pointer in your answer - look at the ubuntu modifications in the preview libreoffice PPA - this will need to be merged & compiled into the standard libreoffice source. – fossfreedom Feb 8 '13 at 11:33
Thanks vasa1 that fixed the icon issue! i will ask the global-menu not working in a separate question. – blade19899 Feb 8 '13 at 13:02

To get standard icons back on launcher please follow instructions: How can I change default settings for new users?

Ubuntu's default favorites are:

['ubiquity-gtkui.desktop', 'nautilus-home.desktop', 'firefox.desktop', 'libreoffice-writer.desktop', 'libreoffice-calc.desktop', 'libreoffice-impress.desktop', 'ubuntu-software-center.desktop', 'ubuntuone-installer.desktop', 'gnome-control-center.desktop']

But after installation of LO 4.0 correct names would be libreoffice4.0-writer.desktop, libreoffice4.0-calc.desktop and libreoffice4.0-impress.desktop.

After compilation of scheme you can reset launcher icons to default using:

gsettings reset com.canonical.Unity.Launcher favorites

or customize current user's launcher icons by setting value of favorites key, e.g.:

gsettings set com.canonical.Unity.Launcher favorites "['ubiquity-gtkui.desktop', 'nautilus-home.desktop', 'firefox.desktop', 'libreoffice4.0-writer.desktop', 'libreoffice4.0-calc.desktop', 'libreoffice4.0-impress.desktop', 'ubuntu-software-center.desktop', 'ubuntuone-installer.desktop', 'gnome-control-center.desktop']"

for new default icons.

share|improve this answer

0 down vote

You might want to try a version built specifically for Ubuntu. There are 4.0.1-rc1 packages in ricotz's LibreOffice Backports PPA

It says, however:

THIS IS THE STAGING FOR THE OFFICIAL LIBREOFFICE PPA. The pacakges will be copied there if they turn out well.

INPROGRESS: LibreOffice 4.0 for Precise/12.04 and Quantal/12.10

Apparently they are building the Quantal version (Raring's is already done) of the for the official LibreOffice PPA at the time I am writing this. You should find it soon here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.