Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.10 and don't see a bluez_card profile on my system:

$ pactl list cards short
0   alsa_card.pci-0000_00_1b.0  module-alsa-card.c   

I tried to load the module as suggested here 12.04 - Bluetooth headset disappeared

$ pactl load-module module-alsa-sink device=bluetooth
Failure: Timeout 

I am trying to get the Bluetooth card profile to display so that I can set it up like it is done here : Why did my Bluetooth headset disappear from Sound Settings and how can I get it back?

$ pactl list cards short
0   alsa_card.pci-0000_01_00.1  module-alsa-card.c
1   alsa_card.usb-Generic_Turtle_Beach_USB_Headset_0000000001-00-Headset    module-alsa-card.c
2   alsa_card.pci-0000_00_14.2  module-alsa-card.c
8   bluez_card.C8_84_47_04_21_6F    module-bluetooth-device.c

$ pactl set-card-profile bluez_card.C8_84_47_04_21_6F a2dp

Update

I have the pulseaudio-module-bluetooth package installed. I tried loading the module module-bluetooth-discover but nothing happens. How can I set this up in /etc/pulse/default.pa?

Now in the sound settings the Ouput tab is selected but under where it says Play sound through there are no items showing anymore.

When i try listing all of the profile cards it says Connection failure

$ pactl list cards short
Connection failure: Connection refused

Update #2

The answer to this post : Sound settings panel empty on 12.04 helped me solve the no sound options problem.

However, I am now back to:

$ pactl list cards short
0   alsa_card.pci-0000_00_1b.0  module-alsa-card.c

Update #3

After uninstalling and reinstalling the pulseaudio package, I tried loading the bluetooth module module-bluetooth-discover. The first time I ran it, it output Welcome to PulseAudio! Use "help" for usage information. Then I checked the profile cards but no bluetooth card displays:

$ pactl list cards short 
0 alsa_card.pci-0000_00_1b.0    module-alsa-card.c 

I loaded the bluetooth module again and this time it output: Welcome to PulseAudio! Use "help" for usage information. >>> Module load failed.

I checked and now the bluetooth card displays. Strange behavior, but it works now. Thanks @Takkat.

Update #4

This just went out again. I tried removing and reinstalling the pulseaudio-module-bluetooth package, and loading the module module-bluetooth-discover but i am back to where I started.

$ pactl list cards short 
0 alsa_card.pci-0000_00_1b.0 module-alsa-card.c

Update #5

After installing recent updates from the Update Manager and restarting my machine it is back to working:

$ pactl list cards short
0   alsa_card.pci-0000_00_1b.0  module-alsa-card.c 
1   bluez_card.00_0C_8A_53_70_D0    module-bluetooth-device.c

This whole Bluetooth setup in 12.10 is very unpredictable. Hopefully this gets shored up in 13.04.

share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

To enable bluetooth from pulseaudio we need to make sure we have the follwing package installed:

Then we also need to load the module-bluetooth-discover to make use of a Bluetooth audio device from pulseaudio.

pacmd load-module module-bluetooth-discover

This can also be done from our default.pa to be loaded on starting the pulseaudio sound server.

share|improve this answer
    
This was very useful. Anyway it is not possible to choose Stereo mode in my "Jabra Halo" headset, but only low quality. In Raring 13.04 it worked... –  leonard vertighel Nov 27 '13 at 5:14
    
@leonardvertighel See if your device has a2dp profile pacmd list-cards. See also: askubuntu.com/questions/159064/… for more on changing profile from CLI. –  Takkat Nov 27 '13 at 7:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.