Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is Samsung NP-Q430-JS03US. I have searched for the solution. I have tried editing grub acpi_osi=Linux and acpi_backlight=vendor, but still didn't work.

Please help.

share|improve this question

7 Answers 7

Try using xbacklight.

  • Install it by running sudo apt-get install xbacklight in a terminal.
  • Change brightness by xbacklight -set <level>, where <level> is an integer ranging from 0 to 100 (lowest brightness to highest).

For example, to set medium brightness one would use

xbacklight -set 50
share|improve this answer
    
this does not seem to work on Samsung laptops –  JCLL Aug 5 at 21:25
    
This works for me in my Lenovo laptop. Thanks alot. –  Dini88 Oct 14 at 16:03

Your laptop is Optimus-enabled. That means that it has two video cards: an Intel card and a Nvidia one (meant to be used for games only). This is problematic because Optimus has been designed to work with Microsoft Windows, and Ubuntu won't play very good with it.

Please check your BIOS setup, whether the Optimus option is enabled or not --if there's even any Optimus settings.

With Optimus enabled, your display will be managed by the Intel card. The brightness controls should work out-of-the-box. The Nvidia card will be fully-powered all the time though, and you need to setup Bumblebee to avoid this and to be able to use the Nvidia card for gaming.

With Optimus disabled, your display will be managed by the Nvidia card, and you'll lose the brightness controls, since the Nvidia card is not capable of accessing them.

share|improve this answer

Did you install the non-free NVIDIA drivers from the Software Sources application? In that case:

Open a terminal and type:

sudo nvidia-xconfig
sudo gedit /etc/X11/xorg.conf

Scroll to the Device section in the text file that appears and add this line in it:

     Option         "RegistryDwords" "EnableBrightnessControl=1;"

Save the file.

Restart.

share|improve this answer
    
this worked for me on my 2010 macbook pro, thanks –  Dirk Feb 6 at 10:19
    
I love you man! –  user69656 May 8 at 17:11

I have a Samsung NP300E5a with Optimus. Same problem after upgrading to Kernel 3.5.0-31-generic. I found a solution that works for me here "Brightness problem on a Samsung 530U3B". Details below

Add the "Linux On My Samsung" repository to the sources list: Code:

sudo add-apt-repository ppa:voria/ppa
Update the programs list:

Code:

sudo apt-get update
Install samsung-backlight:

Code:

sudo apt-get install samsung-backlight
Restart the system and check if backlight control works
share|improve this answer

I believe you should sudo open /etc/default/grub, find the line that starts with GRUB_CMDLINE_LINUX_DEFAULT and make it look like this:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash pcie_aspm=force acpi_osi=Linux i915.i915_enable_rc6=1″
share|improve this answer

I have tried with xbacklight with no exit. It did not recognized the program or similar (new user). However I tried with xrandrand it is perfect. I link the one I used. It is great and my eyes are happy How to change LCD brightness from command line (or via script)?

share|improve this answer
2  
Don't post just an link as an answer. Post the instuctions what to do with the link as a source. –  Pabi Jul 30 at 10:19

---->>>> TRY THIS CODE BY " PROFESSIONALS " <<<<<-----

Go to terminal

Type code : cd /etc/default/

Next it appears like /etc/default$

Type code : Sudo vim grub

A will see a new window in that find the line like below and exit it .

code : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

code : GRUB_CMDLINE_LINUX="acpi_osi=\"Linux\""

After completing editing save it by command like :wq press enter.

now edited window will be close and terminal will appears now type

code : SUDO UPDATE GRUB code : Next SUDO reboot

now your Brightness will be changes . SUCCESS :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.