Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a completely down server at this point. I am new to linux and brought up a server on ubuntu 12.10. I wanted to try KVM so I setup /etc/network/interfaces correctly for a bridge. As I learned a little more about the networking tools, I decided to use ethtool to change the speed of the bridge. I happened to place the ethtool command in the wrong location in the file and now the entire server boots to a screwed up GUI and I don't know how to recover. I could reinstall the server but I am really tired of doing that with ubuntu. I think the problem is that ubuntu doesn't like my Radeon 7400 graphics card or something so it is really hard to get installed in the first place since it gives a blank screen half the time. Now, after making this change to the the interfaces file, it screwed up the entire display. How in the world does changing a network config screw up the entire graphics display? I am pretty unimpressed with ubuntu at this point. It seems very unstable and difficult to install. Any thoughts on how I might recover without another reinstall? I tried using a live CD but it won't work because it can't seem to recognize the graphics card to give me any type of display.

share|improve this question
    
This and This is your probable solution to get display correctly. If you have intel/AMD hybrid graphics look Here –  Web-E Feb 8 '13 at 6:11

1 Answer 1

Found a solution. Instead of messing with the Graphics detection, I learned how to use the recovery features. Basically reboot and immediately started pressing ESC until my BIOS interface came up. One of the options is to Continue Startup. Selected Continue Startup and immediately started pressing ESC again. This brought me into the boot manager menu where I could select

  • Ubuntu
  • Advanced Options for Ubuntu
  • Access System Setup (basically taking me back to the BIOS setup)

I selected Advanced Options. On the next menu, I selected recovery mode. It will run for a few minutes spitting a bunch of messages to the screen. Eventually I got a recovery menu with a host of options. Many of these looked useful. One option was to boot in graphics safe mode but I did not use it. Since I knew that reverting my last /etc/network/interfaces change would fix the problem, I selected the recovery menu “Drop to root shell prompt”. At that point the file system was mounted readonly which prevented the changing of any config files. So I used the "mount all" command. This mounted the hard drive with rw permissions for root. I then opened the config file in vim editor, made the changes and rebooted the system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.