Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Alright, Im still new to Ubuntu and this has been a frustrating process as I imagined it would be.

Heres the problem, I have a Hp g6 with the broadcom BCM4313. I can get it to connect sometimes by following all sorts of other threads, but when I do the connection speed is 1 Mbps. All of a sudden though, I dont even have the option to connect to a Wifi signal anymore. It doesnt recognize any wifi signals or anything.

After reboot the only way to even connect to wifi is to run sudo modprobe brcmsmac

Any help is greatly appreciated. If you need more info please let me know.

Edit: After fresh Reboot:

eric@EKoshykar-HP:~$ sudo lsmod
[sudo] password for eric: 

Module                  Size  Used by

nls_iso8859_1          12714  1 

snd_hda_codec_hdmi     32049  1 

snd_hda_codec_idt      70210  1 

joydev                 17458  0 

parport_pc             32689  0 

ppdev                  17074  0 

rfcomm                 46620  12 

bnep                   18141  2 

coretemp               13401  0 

kvm                   414071  0 

ghash_clmulni_intel    13221  0 

aesni_intel            51038  0 

cryptd                 20404  2 ghash_clmulni_intel,aesni_intel

aes_x86_64             17256  1 aesni_intel

hp_wmi                 18049  0 

sparse_keymap          13891  1 hp_wmi

microcode              22804  0 

snd_hda_intel          33492  3 

snd_hda_codec         134213  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel

snd_hwdep              17699  1 snd_hda_codec

snd_pcm                96668  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec

snd_seq_midi           13325  0 

snd_rawmidi            30513  1 snd_seq_midi

snd_seq_midi_event     14900  1 snd_seq_midi

snd_seq                61555  2 snd_seq_midi,snd_seq_midi_event

btusb                  22475  0 

bluetooth             209249  22 rfcomm,bnep,btusb

snd_timer              29426  2 snd_pcm,snd_seq

wmi                    19071  1 hp_wmi

snd_seq_device         14498  3 snd_seq_midi,snd_rawmidi,snd_seq

mac_hid                13206  0 

i915                  520621  3 

uvcvideo               76750  0 

videobuf2_core         32852  1 uvcvideo

videodev              120310  2 uvcvideo,videobuf2_core

snd                    78921  16 

snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

videobuf2_vmalloc      12861  1 uvcvideo

videobuf2_memops       13405  1 videobuf2_vmalloc

drm_kms_helper         49113  1 i915

drm                   288721  4 i915,drm_kms_helper

i2c_algo_bit           13414  1 i915

video                  19336  1 i915

mei                    40691  0 

psmouse                95595  0 

serio_raw              13216  0 

lpc_ich                17062  0 

rts_pstor             433850  0 

soundcore              15048  1 snd

snd_page_alloc         18485  2 snd_hda_intel,snd_pcm

lp                     17760  0 

parport                46346  3 parport_pc,ppdev,lp

usb_storage            48839  1 

r8169                  61651  0 

eric@EKoshykar-HP:~$ 



Sudo iwconfig

user@host:~$ sudo iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"L1nk5y5"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:25:9C:C3:89:F6   
          Bit Rate=1 Mb/s   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=22/70  Signal level=-88 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:60   Missed beacon:0

user@host:~$ 

And the final comand has no output?

share|improve this question

marked as duplicate by Luis Alvarado Mar 22 '13 at 13:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
did you solved you prblem, i'm having the same issue with the same material hp g6 64bit broadcom 4313 –  radislav Mar 22 '13 at 12:51
add comment

3 Answers 3

I solved the Problem! I followed the first few steps Here: http://www.broadcom.com/docs/linux_sta/README.txt

After "On Ubuntu, you will need headers and tools." Try these commands:

sudo apt-get install build-essential linux-headers-generic
sudo apt-get build-dep linux

Everything worked! thanks for all the help!

share|improve this answer
add comment

http://www.hitxp.com/articles/software/ubuntu-fix-slow-wireless-internet-connection-speed-upgrading-11-04-natty-narwhal/

This site has some tips for speeding up the wifi on Broadcom devices (including disabling power management). I have the same card in my Acer notebook, and it has given me nothing but grief. The best advice I have is to COMPLETELY REMOVE the proprietary drivers, then reinstall. Like so:

sudo apt-get purge bcmwl-kernel-source

then go into the software sources/proprietary drivers app and enable broadcom drivers from there again. Then reboot. Also, make sure that you don't have any other driver modules loaded -- I can give you a list to try unloading if you need it. To unload a module:

sudo rmmod <MODULE>

Hope that helps!

share|improve this answer
    
No dice. Thanks for the help though. Im actually back offline completely –  Eric Feb 8 '13 at 1:18
    
You have a lot of wireless modules loaded...almost all the ones I've ever used. I'm trying to figure out which ones are ACTUALLY necessary...did you run the lsmod command after a fresh reboot? –  clappboard Feb 8 '13 at 2:51
    
Uhm, not entirely sure to be honest, should I retry? –  Eric Feb 8 '13 at 3:10
    
@Eric It would probably be best if you did so...but before you reboot, run the sudo apt-get purge bcmwl-kernel-source command I previously mentioned. Then reboot, and immediately after logging in, run the lsmod command and post the output back here. –  clappboard Feb 8 '13 at 15:42
    
I followed your directions and updated the lsmod output. Note that when I rebooted it kicked me off the web and does not have the option to reconnect. The only way I have found to even get on the internet is to run sudo modprobe brcmsmac. IDk if thats a hint? –  Eric Feb 8 '13 at 16:53
add comment

Didn't try it in 12.10, but sudo iwconfig wlan0 power off worked most of the time in 11.10. This disables the power management and runs wireless at full power all of the time.

edit: try this

  1. open terminal (ctrl-alt-t)
  2. type sudo nano /etc/modprobe.d/blacklist.conf
  3. scroll to the bottom od the file and add blacklist bcma
  4. save and exit (ctrl-x)
  5. reboot.

edit:

got one g6 online. first, sudo apt-get install bcmwl-kernel-source. these are the contents of /etc/modprobe.d/blacklist-bcm43.conf:

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmsmac
blacklist bcma

after reboot try sudo iwconfig ethX/wlanX power off

share|improve this answer
    
Nothing, the power management is already turned off. Thanks though –  Eric Feb 8 '13 at 0:41
    
what steps have you taken thus far, did you do the blacklist thingy? I'll look up some tutorials that did it for me if you haven't. –  sostacked Feb 8 '13 at 0:44
    
I havent tried that, Im not exactly sure how to do it though. Ive tried sudo apt-get update and such but to no avail –  Eric Feb 8 '13 at 0:46
    
did you enable the driver in system settings / software sources / additional drivers? –  sostacked Feb 8 '13 at 0:50
    
Yes, Makes no difference if it is enabled or not. –  Eric Feb 8 '13 at 0:52
show 8 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.