Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run sudo airmon-ng start wlan0, I get this as the output:

dell@ubuntu:~$ sudo airmon-ng start wlan0
[sudo] password for dell: 
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
-e 
PID Name
1545    avahi-daemon
1546    avahi-daemon
1552    NetworkManager
1615    wpa_supplicant
11753   dhclient
Process with PID 11753 (dhclient) is running on interface eth1


Interface   Chipset     Driver

eth1        Unknown     wl - [phy0]

Why is the chipset unknown?

It should say something like this "(monitor mode enabled on mon0)"

share|improve this question
1  
It looks to me like some of the output is missing. Could you edit the question and include all of it? Also, what do you mean by "no monitor is found"? –  Flimm Feb 7 '13 at 22:14
    
Run iwconfig and see which interface does NOT have no wireless extensions besides it's name. That's the one you should use. Network Manager usually interferes with airmon-ng, as suggested on the output... Try stopping it, or, alternatively, using Backtrack, which is Ubuntu with root as default, optional X server, a handful of network exploitation tools such as aircrack-ng, ettercap, nmap, wireshark... and no unnecessary processes that could interfere with them. –  Alex Apr 6 '13 at 21:27
    
you should specify your wireless chipset and any custom configurations. phy0 should typically not present as eth0/eth1 –  hbdgaf Sep 7 '13 at 12:50

1 Answer 1

It looks like your wifi interface is not enabled.

This could be caused by your wifi hardware switch being off or (if you don't have wifi at all) using the wrong interface. I imagine you mean eth1 (wired/ethernet interface) instead of wlan0 (wifi interface).

Try this:

sudo airmon-ng start eth1
share|improve this answer
    
Some modules use ethX as base. –  Braiam Sep 12 '13 at 12:29

protected by Community Jun 11 '13 at 3:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.