Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was coding my site on Apache Server. Suddenly an error came and I got the warning

This computer has only 1.3 GB remaining.

I knew that this was because of the log file in /var/log/apache2/subins/error.log.

I opened the folder in root and the file size of the log was 17 GB. I deleted the error file. I went on to the root trash folder to delete the log file permanently. I deleted the files and info folder in the 'root trash' folder. So I had erased the root trash folder. But things got wrong. I still get the warning

This computer has only 1.3 GB remaining

I think I did the wrong way to empty root trash.

I used Disk Usage Analyzer to find the log file to permanently delete . But the software didn't showed the file. What happened to the folder I deleted in 'root trash'?

Here's the screenshot of Disk Usage Analyzer after the search. enter image description here

UPDATE: Now my computer memory is 1 KB after I run the web page again in which the error showed.

Output of df -T -H:

Filesystem    Type     Size   Used  Avail Use% Mounted on
/dev/sda7     ext4      40G    38G    21k 100% /
none      devtmpfs     455M   291k   455M   1% /dev
none         tmpfs     460M   3.4M   456M   1% /dev/shm
none         tmpfs     460M   312k   459M   1% /var/run
share|improve this question
    
Maybe it is a different file? –  Nanne Feb 7 '13 at 14:39
    
The log file's size is 17 GB! I have no other file in my computer more than 3 GB. –  Subin Feb 7 '13 at 14:40
    
But if the file isn't there anymore and there is still too little space, I would suspect another file? –  Nanne Feb 7 '13 at 14:52
    
Updated the post. See the image - i.stack.imgur.com/0PLmF.png –  Subin Feb 7 '13 at 15:02
    
please post the output for df -T -H –  gajdipajti Feb 7 '13 at 15:11
show 6 more comments

3 Answers

try and look for big files in your system

find / -type f -size +10000k -exec ls -lh {} \; 

then delete them and make some room for other files.

share|improve this answer
    
I still can't find the big file. I got a maximum of 300 MB size file when searching for big files using the mentioned command. –  Subin Feb 7 '13 at 14:37
    
try the following, it will scan your whole system for large files not only in your current directory find / -type f -size +10000k -exec ls -lh {} \; –  user1007727 Feb 7 '13 at 14:44
    
I still can't find the big file. I got a maximum of 300 MB size file when searching for big files using the mentioned command- Same thing. –  Subin Feb 7 '13 at 14:48
    
I tried it on my PC, and it shows files up to 10GB, so the max file size in your PC is 300MB, or you are doing something wrong :) –  user1007727 Feb 7 '13 at 15:13
add comment
up vote 0 down vote accepted

I rebooted my computer as told by gajdipajti

I restarted my computer and the problem is solved. I got the lost memory back. Now I have 19.6 GB free as before the memory increase of log file.

So I think the solution is Restart the computer.

share|improve this answer
    
normally or with forced fsck? –  gajdipajti Feb 7 '13 at 17:57
    
@gajdipajti normally. –  Subin Feb 8 '13 at 13:52
add comment

Files are not deleted on the filesystem if even one process has an open file handle to such files. This was likely the case with your log file, and this is why rebooting solved the issue.

Also, disk space and memory usually mean different things.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.