Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing a problem with installing plugins in Eclipse on Ubuntu 12.04.

I am using the "Install New Software" feature under the help menu in Eclipse. No matter what update site I provide in the "work with" text box, Eclipse simply gets stuck on pending. There is no error message or error window that pops up.

What have I tried so far :

  1. I have tried downloading different versions of eclipse but the problem seems to persist across all the versions.
  2. I have tried the Direct and Native Active Providers in the Window->Preferences->General->Network Connections window. (I have proxy settings configured in Ubuntu which get used in eclipse when using the Native Active provider)
  3. I was only able to get rid of the problem by connecting to another network through VPN and then choosing the Direct Active provider.

Connecting to another network through VPN seems to be a workaround. Is there a solution that will let me install plugins in eclipse through the "Install New Software" feature without the need to connect to another network?

share|improve this question

1 Answer 1

I discovered answer to this question completely by chance.

The trick is to keep only HTTP and HTTPS proxy values in "manual" settings. Keep the SOCKS proxy empty.

As soon as we set these settings, eclipse successfully fetches the list of plugins, and successfully installs plugins too!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.