Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I am trying out GBrowse, as we will use this later on.

But then, I'm getting this

------------------------------------------------------------------------------------------------
256000 features loaded in 230.29s ( 1.19s/1000 features)...                                                                                
Building object tree... 6.78s.47s                                                                                
Loading bulk data into database.../tmp/feature.12240
DBD::mysql::db do failed: The used command is not allowed with this MySQL version at /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store/DBI/mysql.pm line 571, <GEN0> line 256232.

-------------------- EXCEPTION --------------------
MSG: The used command is not allowed with this MySQL version
STACK Bio::DB::SeqFeature::Store::DBI::mysql::_finish_bulk_update /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store/DBI/mysql.pm:571
STACK Bio::DB::SeqFeature::Store::finish_bulk_update /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store.pm:1505
STACK Bio::DB::SeqFeature::Store::GFF3Loader::finish_load /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store/GFF3Loader.pm:349
STACK Bio::DB::SeqFeature::Store::Loader::load_fh /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store/Loader.pm:354
STACK Bio::DB::SeqFeature::Store::Loader::load /usr/local/share/perl/5.14.2/Bio/DB/SeqFeature/Store/Loader.pm:243
STACK toplevel bp_seqfeature_load.pl:103
------------------------------------------------------------------------------------------------

I've tried doing what's said here: http://www.markhneedham.com/blog/2011/01/18/mysql-the-used-command-is-not-allowed-with-this-mysql-version/ , also in the part http://dev.mysql.com/doc/refman/5.0/en/load-data-local.html

If you use LOAD DATA LOCAL in Perl scripts or other programs that read the [client] group from option files, you can add the local-infile=1 option to that group. However, to keep this from causing problems for programs that do not understand local-infile, specify it using the loose- prefix:

. So I'm desperate now - is there such a thing in ubuntu? Because as I see it in Windows, you can easily edit in the Services snap-in viewer. What I intend to do is add the --local-infile=1 parameter to the mysqld executable when the script/program that starts the MySQL service is called.

share|improve this question
    
Are you installing the package from the official repostories or from a custom installation script? –  Paul van Schayck Feb 7 '13 at 9:11
    
Yup, official repositories. GBrowse files came from their website while the Perl libraries, installed via CPAN as specified in the GBrowse tutorials. –  abrahamdsl Feb 8 '13 at 0:45
    
That's not what I meant. By official I meant the Ubuntu repositories. It has a ready to go GBrowse package. Was there any reason not to use those? –  Paul van Schayck Feb 8 '13 at 9:34
    
Oh, I didn't know that. But anyway, I'm just told to try it out - I'm not yet sure what OS we will be using on production so I think it is better to stick with the step-by-step GBrowse installation as much as possible. –  abrahamdsl Feb 9 '13 at 14:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.