Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a motherboard with an Atheros R8161 network interface card, running on Ubuntu 10.04 LTS 64bit with 3.2.0-030200-generic kernel.

I've built and installed the alx drivers from linuxfoundation.com.

After installation, the NIC shows up at eth2 according to ifconfig.

I've then also included the following lines in /etc/network to configure the interface

auto eth2
iface eth2 inet dhcp

However, even after these steps, I'm still getting a "ADDRCONF(NETDEV_UP): eth2: link is not ready" in dmesg.

Additionally, in dmesg, udev renamed eth0 to eth2.

My router detects a link with a lit port LED when the NIC is connected to my router though, but I can't ping it.

I've also tried installing a really old PCI NIC and it got detected as eth3 upon bootup without any intervention, but I still can't ping the router.

Does anyone know how I might be able to fix this?

Thanks.

share|improve this question
add comment

1 Answer

These suggestions assume you are using the Gnome desktop environment.

Try using the Network Manager UI to manage the interfaces instead of editing the /etc/network/interfaces configuration file directly, and assign a static IP address to the interface through that UI.

The package name is network-manager-gnome if you need to find and install it.

Ref URL: http://packages.ubuntu.com/lucid/network-manager-gnome

Now, these screenshots below are from my box which is running 12.04 LTS but, from what I can see in the links, 10.04 LTS is no different.

Once you've done that, you can check the interfaces's configuration with ifconfig from a terminal and then see if you can ping the gateway address which I expect will be your router's IP address.

It's worth mentioning, for the sake of it having been said, to make sure the netmask is correct i.e. the same netmask as your router.

Wired Ethernet interface

On my LAN, the gateway address shown (below) is my router's IP address; the router also serves DNS to the LAN which is why this IP address is also shown as a DNS server.

If you aren't sure if you have a DNS server on your LAN, you can use Google's DNS servers: 8.8.8.8 and/or 8.8.4.4.

If you can ping your gateway address, and get a response, you can use dig google.com from a terminal to see if you're getting name resolution.

If that all works, you've verified you have network and internet connectivity and can assume that it's the DHCP server that is not providing an IP address (at least in this case).

IPv4 Settings

Leland Kristie

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.