Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I maximize flash to full screen mode, it lags. The video renders slowly even though the sound is playing smoothly.

I think this might be caused by an issue I'm facing with installing the correct video driver for my computer, an "HP dv4 2154ca" .

I've tried to install the driver a couple of times, but the xorg.conf file is still empty no matter what.

So my question is, why is this file empty, and how could I generate it correctly for my device? Is this the cause of my video rendering problems in flash?

Thanks in advance.

share|improve this question

2 Answers 2

By default, there no longer is an xorg.conf file as everything is autodetected at this point. I can't answer why fullscreen flash is having trouble, based on what I can tell your computer shouldn't have trouble with that.

share|improve this answer

This bug is very possibly the cause of your problem.

From there, you can try the GPU validation trick :

sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/

But many people have reported that Compiz prevents this fix from working properly, so you might be out of luck until a revised flash-plugin becomes available.

Another option might be to switch to Chromium, as it uses an inbuilt version of flashplugin. To be honest, that just means that Chromium's flashplugin might be a little more up to date, but ultimately it's still just flashplugin, so possibly a dead end.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.