Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New to ubuntu (just 5 hours) and these forums, so hello :)

Here's a summary of what happened. Had windows xp installed this morning, thought I'd give ubuntu a whirl since I was planning on using it on my just ordered odroid u2, installed it through usb (copied the important data on there to one of my three partitions, formatted it and installed ubuntu through that) & decided to replace windows xp with ubuntu during installation because of random issues I was having with it. Now I'm having trouble accessing my drive. I can see my drive under computer but it says 'Unable to mount location'

Sorry if this is a really noob question, but its 2am here and I need my data in a few hours. I've been searching for quite a bit now. Downloaded GParted, tried mounting it through the terminal, and a couple other things.

edit: running 12.10 btw

share|improve this question
1  
A few preliminary questions: What sort of computer is it? How much memory, what's the CPU? How's it connected to the Internet (wired or wireless)? Did the install seem to go all right or did you get any error messages? When you say you can see your drive "under computer," what do you mean? Do you have a boot menu, or does the computer automatically boot into Ubuntu? –  Kelley Feb 6 '13 at 22:23
    
Intel processor, Dual-Core E5300 @ 2.60GHz × 2 with 4 gigs memory. Connected through wireless, have a USB wireless adapter. Smooth installation, no errors. It shows my 320 gig hdd under computer. And it automatically boots into ubuntu. I'm going to try downloading a copy of 7 and getting it to run on VB. The copy I have atm doesn't seem to work on it. –  Saurabh Feb 7 '13 at 5:21
add comment

2 Answers

Most often linux will refuse to mount it because of errors on the filesystem

try running ntfsfix

http://manpages.ubuntu.com/manpages/hardy/man8/ntfsfix.8.html

it is part of the ntfsprogs package so you should have it.

sudo ntfsfix <options> <device> .. <device> being something like /dev/sda4 etc..

You can get the device name from Disk Utility. Open Unity Launcher and type Disk Utlity

share|improve this answer
add comment

NTFS 3g will not mount a drive thats been uncleanly shutdown. The 'safe'/'easy'/'idiotproof' way would normally be to boot into windows, then shutdown cleanly then boot into linux. You can also 'force' mount the drive.

sudo mount -t ntfs-3g /dev/sdaX /mnt/mountpoint/ -o force

Should do the trick - replace /dev/sdaX with the device name of the partition, and mountpoint with the location you want to mount the drive. This will tell ntfs 3g to ignore the errors and mount the drive anyway.

For more details, take a look at the ntfs 3g manpage.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.