Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems connecting my iPod Touch (2G, running firmware 4.2.1) to Ubuntu 12.10. Whenever I connect it via USB, I get the error message "Unable to Connect." Nothing on a lockdown error. I've tried opening Rhythmbox, Amarok, and gtkPod with the iPod connected, but the device is not showing up at all. I've downloaded the latest libimobiledevice and ifuse, but nothing seems to be working.

I did try Banshee. While the iPod IS showing up, adding music gives me the error message: "The mp3 format is not supported by the device, and no converter was found to convert it." Strangely, looking at its stats: it says there are 6.8 GBs of "Other" stuff and 6.3 GBs of free space (which is odd because my iPod is only 8 GBs).

I've tried "idevicepair unpair" in the Terminal, but I get the error: "Device e730d926557aae2209069e01954c65e3e8444f87 is not paired with this host."

When I tried "ideviceinfo", I get: "GnuTLS error: A TLS packet with unexpected length was received."

I know it's my iPod being problematic because I've successfully been able to connect my girlfriend's iPod Nano. This is also a new laptop. My device worked on my previous laptop (running Lubuntu 12.04 before it died), so I know there's still hope.

If it can be helped, any assistance would be appreciated. Otherwise, I may abandon Apple altogether and use something else. Thank you very much for your time.

share|improve this question

closed as off-topic by Seth, Braiam, Alvar, mikewhatever, Eric Carvalho Dec 27 '13 at 0:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth, Braiam, Alvar, mikewhatever, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

I switched to Ubuntu 12.04.2 (64-bit) and now the iPod works perfectly. I don't know how (or why), but it's working. All the same, I was having other problems with 12.10, so this is a good thing.

Again, thank you for your time.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.