Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install the latest (13.1) ATI propreitary drivers, as mentioned here.

But I'm getting the following error when trying to create .deb packages for use.

.........
.........
# refresh copyright file
cat debian/copyright_stub_0 > debian/copyright
cat usr/share/doc/fglrx/LICENSE.TXT >> debian/copyright
cat debian/copyright_stub_1 >> debian/copyright
#Steps that we can't easily represent in debhelper files or .in files yet
# Remove any libraries that may be caught by shell expansion
find . -name libGLE* | xargs rm -f
find . -name libEGL* | xargs rm -f
dh_installdirs -pfglrx
# Install the QT libraries
dh_install -pfglrx "arch/x86_64/usr/share/ati/lib" "usr/share/ati"
cp: cannot stat `debian/tmp/arch/x86_64/usr/share/ati/lib': No such file or directory
dh_install: cp -a debian/tmp/arch/x86_64/usr/share/ati/lib debian/fglrx/usr/share/ati/ returned exit code 1
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
[Error] Generate Package - error generating package : Ubuntu/quantal

How can I fix this error?

I tried the open Radeon driver, but the laptop was overheating to above 80 degrees C.

I installed the propreitary drivers via the Software Sources window, and the system was running at moderate temperature, but then I couldn't login to Gnome 3 after the reboot, so installing the propreitary drivers properly would be really useful.

share|improve this question
    
For now,I've added the Xorg edgers PPA and installed the open drivers (found at ubuntuupdates.org/ppa/xorg-edgers). The temps still rise to 70 degrees C, but at least it's less than the 80 earlier, and Gnome 3 works. –  Sumesh Feb 7 '13 at 12:22
add comment

1 Answer

From what I read over on ubuntufourms it is a bug in the package installer. To fix it

  1. Extract the package with $sh ./amd-driver-installer-catalyst-12.11-beta11-x86.x86_64.run --extract ~/build/amd-v12.11
  2. Go to the file relative to the above extracted dir: packages/Ubuntu/dists/quantal
  3. Edit the file rules.

On line 242 the text
dh_install -p$(PKG_driver) "arch/x86_64/usr/share/ati/lib" "$(datadir)/ati" should read dh_install -p$(PKG_driver) "arch/x86/usr/share/ati/lib" "$(datadir)/ati"

As you can see it is just an assumption that is made about this script always being run on 64 bit machines.

(Similar fix for other Ubuntus, just fix the packages/Ubuntu/dists/<release> path above.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.