Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

But when I look in the Home folder they show up in the left hand section and I have full access. It looks like I have caused an unintended consequence in trying to find solutions to an earlier problem with the card reader (now fixed).

When I click to dis-mount usb stick or SD/SDHC card I am asked to supply my admin password!

Do I need to fix this situation? If yes, how?

Thank you

njsg, Terminal output as requested and thank you for your patience,

With usb stick in multi-card reader,

roger@roger-desktop:~$ mount
/dev/sda6 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/roger/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=roger)
/dev/sdf1 on /media/usb0 type vfat (rw,noexec,nodev,sync,noatime,nodiratime)
roger@roger-desktop:~$

roger@roger-desktop:~$ dmesg | grep sdf
[  218.603341] sd 9:0:0:0: [sdf] 7806976 512-byte logical blocks: (3.99 GB/3.72 GiB)
[  218.604450] sd 9:0:0:0: [sdf] Write Protect is off
[  218.604455] sd 9:0:0:0: [sdf] Mode Sense: 23 00 00 00
[  218.605449] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.605453] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.610441] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.610448] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.637917]  sdf: sdf1
[  218.643388] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.643396] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.643401] sd 9:0:0:0: [sdf] Attached SCSI removable disk
roger@roger-desktop:~$ 

With usb stick and SDHC card in multi-card reader,

roger@roger-desktop:~$ mount
/dev/sda6 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/roger/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=roger)
/dev/sdf1 on /media/usb0 type vfat (rw,noexec,nodev,sync,noatime,nodiratime)
/dev/sdb1 on /media/usb1 type vfat (rw,noexec,nodev,sync,noatime,nodiratime)
roger@roger-desktop:~$



roger@roger-desktop:~$ dmesg | grep sdf
[  218.603341] sd 9:0:0:0: [sdf] 7806976 512-byte logical blocks: (3.99 GB/3.72 GiB)
[  218.604450] sd 9:0:0:0: [sdf] Write Protect is off
[  218.604455] sd 9:0:0:0: [sdf] Mode Sense: 23 00 00 00
[  218.605449] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.605453] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.610441] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.610448] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.637917]  sdf: sdf1
[  218.643388] sd 9:0:0:0: [sdf] No Caching mode page present
[  218.643396] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[  218.643401] sd 9:0:0:0: [sdf] Attached SCSI removable disk
roger@roger-desktop:~$

Note, where sdf appears in square brackets above it is RED in Terminal.

For both the usb stick and SDHC card I can read and copy to my PC, but I can not write from PC to them. Using Ubuntu Home Folder, Devices, Properties both have msdos file systems. When I plug them into a Windows XP laptop they are both FAT32 file system. Does that mean that Ubuntu sees FAT32 as msdos?

share|improve this question
    
How did you mount it? Which solutions are you talking about? (Un)mounting in UNIX filesystems requires root privileges unless 1) the filesystem is in /etc/fstab and 2) it explicitly has an option allowing any user (or maybe a specific user?) to mount it. There are, although, several tools to bypass this limitation, like gvfs and pmount. It'd help if we knew what exactly did you use. –  njsg Feb 6 '13 at 17:41
    
I now wish I had a record of exactly what I did do. I did install 'Input-utils' via Synaptic Package Manager and listed Medibuntu in Software Sources. –  user127403 Feb 6 '13 at 21:55
    
njsg, I could not provide a copy of the content of /etc/fstab here as it is '187 characters too long'! In the file 'media' there are files for usb0 through to usb7. There is nothing in file 'mnt'. The PC is a desktop that I assembled years ago, now with 12.10 64bit installed and an internal usb connected multi card reader. When I plug in a USB stick the error message is 'Unable to mount FLASH DRIVE Device/dev/sdf1 is already mounted at '/media/usb0'. However the FLASH DRIVE is listed under 'Devices' on lefthand side of 'Home Folder'. –  user127403 Feb 6 '13 at 22:25
    
njsg. Now I can not copy files to the FLASH DRIVE. The error message is 'There was an error copying the file into /media/usb0. Error opening file '/media/usb0/Items for 23 Haddon.odt': Permission denied'. I am still able to copy files from the FLASH DRIVE to my PC. Do I need to back-up all of my data and do a fresh re-install? –  user127403 Feb 6 '13 at 22:31
    
From what you describe, there is something automounting your flash drive. I don't know if this is usual for Ubuntu, but I'd not be surprised if it were. Now, which filesystem is that flash drive using? Are you sure it can be mounted read-write in that computer? Please provide the output of mount in the question, especially the line with /dev/sdf1 (it will be there, the error means the partition has already been mounted, no dark magic there), and also the output of dmesg | grep sdf, which will likely contain error messages if the problem is a corrupt filesystem. –  njsg Feb 7 '13 at 7:47
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.