Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What does that means and how to switch from 2D to 3D. I have a AMD Radeon7670M I tried installing and re installed the driver it recommended in additional drivers and i have checked synaptic package manager all the 2D and 3D related results are marked green.Now What to do i am very confused.

share|improve this question
add comment

4 Answers 4

up vote 5 down vote accepted

Okay, now I have faced this exact same problem myself and solved this a few days previously. My previous answer was in accordance with the standard procedure for troubles regarding logging in to Unity-3D

Apparently, the official drivers that are tested by Ubuntu are not being detected and are in effect worthless.

Here is the solution I found to the issue (quoting from another site) :

http://nerdysermons.blogspot.in/2011/11/solve-graphic-driver-errors-unity-3d.html

There are 3 suggested methods that are given in this post. I have tried all three and the third was the one that worked for me.(That is the option where you install the open source drivers removing all the existing drivers). The second option actually caused my system to hang after the Ubuntu splash screen.

The procedure given in the above site, for simplicity's sake, and for your ease can be summarised as follows:

  1. Prior to taking any of the above approach, run this command to install dependencies :

    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf

  2. Install Open source Graphic Drivers (Recommended) The below command will remove all traces of Ubuntu's default fglrx drivers (if installed).

    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

  3. Remove the existing xorg.conf

    sudo rm /etc/X11/xorg.conf

  4. Reinstall the xorg.conf

    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

  5. Configure xorg

    sudo dpkg-reconfigure xserver-xorg

  6. Reboot the system

    sudo reboot

This worked for me just fine. Hope it works for you too.

share|improve this answer
    
If this post was useful to you please move it up and mark the answer as accepted by using the up arrow and check-box on the left side of this post. Thank you! –  routeaccess Feb 6 '13 at 16:50
    
THANKS ALOT IT WORKED GOD BLESS YOU :) –  Franco Feb 6 '13 at 16:52
    
:) happy to help! –  routeaccess Feb 6 '13 at 16:54
add comment

Ah, this happened to me, and the solution is easy. First, log off. (Or go to the login screen.)enter image description here

enter image description here Now, as shown, click the Ubuntu Logo.

enter image description here

It will open this. Click 'Ubuntu' (Not Ubuntu 2D.) Then sign in as normal. Note: This will always be the default setting. To change it, use these steps again.

Sorry about the formatting. It's quite hard.

Oh, and the options on the 3rd image you might not have.(E.g. GNOME)Unless you installed them.

share|improve this answer
    
echo $DESKTOP_SESSION gives ubuntu -2d in both ubuntu and ubuntu 2D –  Franco Feb 6 '13 at 16:29
    
Ok, before doing this, does the Ubuntu Logo look like the logo is popping out? (Out of the launcher) –  nerof61 Feb 6 '13 at 16:34
    
Yes it's the same –  Franco Feb 6 '13 at 16:38
    
Does it have curved edges? –  nerof61 Feb 6 '13 at 16:40
    
Problem Solved! BTW thanks for the help –  Franco Feb 6 '13 at 16:53
show 2 more comments

To log into the Unity-3D interface you will need to log out and log in again. This time click the icon next to the username and from the two options "Unity 2D" and "Unity" select the second one. Hopefully it will help you, if you have Unity-3D on your system.

To check if you have successfully logged into Unity-3D, run the following code in terminal:

echo $DESKTOP_SESSION

It will return Unity or Unity 2D and you can verify your current session.

Run this code in terminal to check your support of the Unity 3D interface. You will get output that will identify capabilities of your graphics card; one of the items (the last in the list, I think) will tell you if you have "Unity 3D Support:" it'll either give you a "Yes" or a "No."

/usr/lib/nux/unity_support_test -p
share|improve this answer
    
Tried it it's still the same :/ –  Franco Feb 6 '13 at 16:12
    
Answer updated. Post result. –  routeaccess Feb 6 '13 at 16:23
    
echo $DESKTOP_SESSION gives ubuntu -2d in both ubuntu and ubuntu 2D after that i tried the other command and this was the result"X Error of failed request: BadRequest (invalid request code or no such operation) Major opcode of failed request: 154 (GLX) Minor opcode of failed request: 19 (X_GLXQueryServerString) Serial number of failed request: 22 Current serial number in output stream: 22" –  Franco Feb 6 '13 at 16:27
    
Problem Solved! BTW thanks for the help. –  Franco Feb 6 '13 at 16:54
add comment

Unity 2D which is in Precise is a desktop designed to provide the Unity desktop shell on hardware platforms that cannot currently support Unity's OpenGL requirements.

On older machines the standard Unity desktop may not run very well. Unfortunately for those of us with older hardware it is not supported in 12.10 and I believe there is no intention to support it in future versions.

Its architecture is very close to Unity's as it only replaces the user interface elements but still shares all the same backend components. Specifically, Unity 2D replaces the panel, launcher and places components as defined in Unity's architecture overview. Moreover it does not enforce the use of Compiz as a window manager but instead uses a slightly tweaked version of Metacity.

Note: on some old hardware the normal (3D) Unity is not an option and Unity 2D is offered instead.

For more details see here Unity2D

If you want the Unity desktop log out then at the login screen click the circular icon next to you name and the password box. Select "Unity" as your desktop then login again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.