Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have these lines in the fstab

# binds
/media/DataNtfs/Music           /home/can/Music                  none    rw,bind 
/media/DataNtfs/Pictures        /home/can/Pictures               none    rw,bind 
/media/DataNtfs/Downloads       /home/can/Downloads              none    rw,bind 
/media/DataNtfs/Documents       /home/can/Documents              none    rw,bind 
/media/DataNtfs/Backups         /home/can/Backups                none    rw,bind 
/media/DataNtfs/Notes           /home/can/Notes                  none    rw,bind 
/media/DataNtfs/Other           /home/can/Other                  none    rw,bind 
/media/DataNtfs/Packages        /home/can/Packages               none    rw,bind 
/media/DataNtfs/Photos          /home/can/Photos                 none    rw,bind 
/media/DataNtfs/Videos          /home/can/Videos                 none    rw,bind 
/media/DataNtfs/WorkSpace       /home/can/WorkSpace              none    rw,bind 

Here is the screenshot

share|improve this question
    
you can add screenshots now, if you like. –  belacq Feb 6 '13 at 16:45
    
Thank you. I added. –  Can Feb 7 '13 at 22:16
    
add to /etc/fstab x-gvfs-show option to each drive you want to hide in nautilus –  arhimed Jun 16 '13 at 12:34

2 Answers 2

  • Mount them elsewhere. /media is automatically added. Mount them in /mnt and they will not appear (unless someone made a udev rule to do so). Nowadays everything seems to be mounted in /media but it used to be so that /mnt was for internal disks and /media for removable discs. No-one is stopping you from using /mnt!

  • Adding the x-gvfs-show as Arhimed pointed out in comments does not seem to work. This bug #1011257 affects both 12.10 and 13.04 and is due to a package that needs to be updated: util-linux.

  • Besides that you can cancel all automounting from dconf-editor:

enter image description here

share|improve this answer
    
They are not harddisks and not mounted in /media. They are directories and 'bind'ed to home directory. –  Can Jul 3 '13 at 9:01
    
So? Like I said: change /media/DataNtfs/Music to /mnt/DataNtfs/Music and they will not show in Nautilus Devices pane. Anything in /media is automatically 'mounted' by Nautilus unless you change the dconf setting. –  Rinzwind Jul 3 '13 at 9:33
    
I understand you. I upgraded 13.04 and its okay now. Thanks. –  Can Jul 3 '13 at 13:06

I upgraded 13.04 and they gone. I think developers take that as a wrong feature instead of a bug, and they fix it in 13.04. I suggest you to upgrade.

This is my home directory

I liked new look of the nautilus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.