Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problem connecting to ad-hoc I created in ubuntu 12.04.1 LTS.

My office have a restricted (and very slow) Wifi which isnt much of any use.

So I figured I could create an ad-hoc in my laptop connected via cable to enjoy the fast and unrestricted connection from my iPhone. And it worked well until 2 weeks ago.

I believe one of the Ubuntu updates (or even iOS update, not sure) affected somehow this connection. From 2 weeks until now, whenever I try to connect my ad-hoc (WEP 40/128bit Key) from my iPhone I am prompted to inform a username and a password.

I have tried all kind of possible usernames and none have worked. I don't even know which password is to be used... Is it my Ubuntu users pass? The pass I configured the connection with?

Once again, I can't tell if the problem is the Ubuntu or the iOS.. But I can't find any solution and figured someone out here would be going through the same (or gone through).

Any help is much appreciated! Thanks.

share|improve this question
add comment

1 Answer 1

I'm not answering the question, but I can't post comment yet. Sorry for that.

Do you know that WEP is completely broken? You'd better not encrypt anything: it will be as efficient to protect you and you won't have any user/password problem.

You can try to set up a WPA ad-hoc connection using:

ap_scan=2
network={
    ssid="MySSID"
    mode=1
    freq=2412
    key_mgmt=WPA-PSK
    proto=RSN
    pairwise=CCMP
    group=CCMP
    psk="passwd"
} 

and launch it using

wpa_supplicant -cfile.conf -iwlan0 -Dwext

You can also try to get connection from USB. I did that months ago with my android phone (internet connection on the laptop --> mobile phone)

share|improve this answer
    
I didn't know WEP is completely broken. I know i can share my 3G to the computer from my iPhone, but I don't think I can do it the other way around. Maybe with tweak or app from Cydia? –  mlmfilho Feb 7 '13 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.