Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(Using Virtual Box 4.2.0, Ubuntu 12.10 64bit)

Although the GuestAdditions and 3D acceleration instructions were meant for 4.2.4 and 4.2.6 I wanted to try them for 4.2.0.

Now that I start the VM, I get a black command prompt screen.

As I am new to Linux, I tried to remove the last line from the modules file in /etc/ by typing

sed '$d' < modules

This did remove the vboxvideo line but I'm still getting the black command screen.

How do I get back the standard visual desktop?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The appropriate way to uninstall guest additions from a virtual box guest is to run the script provided:

user@guset:$ sudo ./opt/<VirtualBoxAddtions-x.x.xx>/uninstall.sh

Replace the x placeholders with the ones for your vitualbox version.

Alternatively you can try to install the appropriate version of the guest additions over the existing guest additions. A command line way to do this is outlined here:

However it is strongly recommended to upgrade virtual box to the most recent version to be able to run the latest Ubuntu release without issues.

share|improve this answer
    
thanks... it keeps giving me command not found. I tried ./opt/VirtualBoxAdditions-4.2.0/uninstall.sh; I also tried ./opt/VBoxGuestAdditions_4.2.0; also tried without opt/. –  Raza Ali Feb 6 '13 at 12:33
    
By the way, i also tried sudo -X configure. It lists a bunch of video drivers and then says that "Number of created screens does not match number of detected devices" –  Raza Ali Feb 6 '13 at 12:34
    
Update: i purged xorg, installed it again, reinstalled intel drivers. Removed .Xauthority. Rebooted. It showed the ubuntu loading screen for a split second then went back to terminal. sudo X -configure keeps giving the message that number of screens does not match number of detected devices. –  Raza Ali Feb 6 '13 at 13:27
    
All Praise to the Lord! Thank you Takkat! I upgraded to 4.2.6 and installed guest additions using the command line. Desktop is back. –  Raza Ali Feb 6 '13 at 14:24
    
My saying... recent versions for recent versions. Good you got everything worked out. :) –  Takkat Feb 6 '13 at 14:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.