Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use the VT (CTRL+ALT+F1),it will only display replacement characters for chinese, but from the alternative installation CD I can see, that it's actually possible to display chinese in the VT. How to enable this?

share|improve this question
    
I booted into a chinese livecd. I hit ctl-alt-f1 to get to the console, and found it did not display chinese characters. I'm using a 10.10 ubuntu desktop iso. I had to install and run fbiterm to get the console to show chinese. Is your experience different? How so? –  djeikyb Feb 12 '11 at 1:36
    
Also, when you installed ubuntu, did you install in english, or chinese? Please run locale and add it's output to your question. –  djeikyb Feb 12 '11 at 5:43
    
I installed the german version of ubuntu. locale days de_DE.utf8 everywhere. –  FUZxxl Feb 12 '11 at 22:04

2 Answers 2

I booted the 10.10 32-bit Ubuntu livecd, and chose what I'm pretty sure is simplified chinese (second to last option on the language menu). After it booted into the trial environment, I hit ctl-alt-f1, typed ls, and was rewarded with diamonds instead of chinese. I conclude Ubuntu does not include chinese support for console/tty. Otoh, everything works wonderfully inside Gnome.

Fortunately, you can add chinese tty support. Install fbiterm and run it on a tty. It's a frame buffer that can deal with non-latin characters. I don't know yet how to make fbiterm used by default.

@FUZxxl, running fbiterm on a fresh install of Ubuntu 10.10 in VirtualBox gives me your error Frame buffer device /dev/fb0: Open error. I found an UbuntuForum.org thread that suggests you need to load the kernel module that allows frame buffers. It's a bit old..here's what I did:

  1. Edit /etc/initramfs-tools/modules. Add to the end of the file on separate lines: fbcon and vesafb.

  2. Edit /etc/modprobe.d/blacklist-framebuffer and uncomment vesafb.

  3. Run: sudo update-initramfs -u -k all.

  4. Make sure you have a vga line set in /etc/default/grub. Example: GRUB_CMDLINE_LINUX_DEFAULT="vga=0x314"

  5. Run update-grub.

Now you can reboot and run fbiterm at the virtual console.

share|improve this answer
    
Thank you very much for this answer. To you know, which solution is used by the ubuntu alternate installer? –  FUZxxl Feb 10 '11 at 18:57
    
Hm... Very bad. They all don't work on my machine. Maybe it's an issue with the nvidia driver. –  FUZxxl Feb 11 '11 at 6:29
    
First, the screen goes black. –  FUZxxl Feb 12 '11 at 18:05
    
Than nothing happens. If you change to another VT and back, there appears another message: Frame buffer device /dev/fb0: Open error. I guess it's something about the nVidia driver (as always...) –  FUZxxl Feb 12 '11 at 19:04
    
I wouldn't give up yet. I reproduced the error without using an nvidia gfx driver. –  djeikyb Feb 13 '11 at 9:45

I think, true "text mode" VT uses text video mode, so it's limited to 256/512 different chars at the same time. I don't know too much about the Chinese language, but I guess it has much more "letters" that other languages having an "alphabet" with 26 letters or so :) Though, I think Ubuntu uses framebuffer VT console (not text VGA mode based), so maybe in theory it's possible to do ...

share|improve this answer
    
Do you know Clonezilla? If you start it, it will ask you for language settings. For instance, it will say 正體中文. As you can clearly see, clonezilla uses something VT-alike, so it couldn't be that difficult. –  FUZxxl Feb 12 '11 at 18:02
    
Looking at ps -e|grep fb, /etc/modprobe.d/blacklist-framebuffer.conf, and lsmod|grep fb, Ubuntu does not use a framebuffer. Confirmed with 10.04 and 10.10. –  djeikyb Feb 13 '11 at 4:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.