Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.10 and whenever I click on .tex file it says it is an executable file. I wanted to remove this and tried gksu nautilus, but I can't tick off the permission. When I try to remove the tick, it automatically ticks on.

share|improve this question

2 Answers 2

Probably you do not have permission for change permissions.

By the way, in Linux any file with the execute permission is considered as executable. No matter if it actually contains anything that could be executed or not.

You can set Nautilus to always open files instead of executing them. To do that just open a file manager window, go to Edit->Preferences, and on the Behavior-tab set it to "View Executable files when they are opened"

Also try to change permissions in terminal using chmod -x (and if you have no permissions ro change permissions sudo chmod -x), something like sudo chmod -x file.tex (here r are saying that file.tex is not executable).

share|improve this answer
    
Thank you very much. It worked perfectly. –  Ashok Feb 6 '13 at 7:24
    
@Ashok: it it helped you, please accept this answer by clicking on the check mark. –  guntbert Feb 6 '13 at 12:20

There are mainly two reason

  1. File system is Read only
  2. Not supported FS (like Windows ntfs,fat etc)
share|improve this answer
    
is there any way to do it on NTFS –  Erogol Nov 20 '13 at 13:37
    
No. What's your scenario? –  totti Nov 22 '13 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.