Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem almost fits mine. His font is Helvetica, mine are Cambria/Calibri, his ligatures display as bolded, mine - not at all. So, meetings become meengs, litigation becomes ligaon, etc. Makes for a hard read!

Now, if I modify CSS etc. this helps one page. I can try Stylish but I don't want to (this may change later). I also prefer to have these MS C-fonts degrade gracefully, than to have to install them (especially since I've read for this I'll also have to run Windoze on my device).

This caused me to learn great deal about fonts in Ubuntu and in general, but I am new to topic, so if I dig under wrong tree, please point me to right one. ;-)

Test sites: anything that uses Calibri. Jeff's Coding Horror is one, here is another (look at title, it's missing tt in little in my case): http://nabble.documentfoundation.org/A-little-info-about-ligatures-and-e-g-Calibri-td4034178.html

Tried - no avail

  • most common solution (add to .fonts.conf code to disable embedded bitmaps)
  • adding CSS to disable ligatures for FF (-moz-font-feature-settings: "liga=0";).
  • fc-match Calibri returns Calibri Regular:
    1. Changing (via Firebug) Calibri to Calibri Regular shows all letters as needed, pages display as they should, meetings become meetings and litigations are litigations.
    2. Aliasing Calibri to Calibri Regular via in .fonts.conf file - does nothing
  • rebuilded fonts cache with sudo fc-cache -v -f
  • checked if not on Nouveau drivers - no
  • adjusted settings in Settings > Appearances > Fonts - my fonts look really nice now!, but Calibri in FF still looses what it was loosing
  • toggling configs in /etc/fonts/conf.avail/, namely antialiasing, autohinting and bitmap-rejecting, but none gave any (good, not to mention desired) effects.
  • removing mscorefonts package

Remains to try

  • cairo-ubuntu and font-config-infinality (or how it was called), from ArchLinux forum
  • something with blank ligatures via FontConfig user page
  • replacing font instead of aliasing, but aliasing seems to be preferred for narrowing font family (Courier -> Courier New)
  • try to see if it's not a bug, like with not showing ligatures if font under 20px - and see FF config for changes

If you want me to add something, just ask. It's late and I'm spent on it 6 hours now, learning about many different font-related things - interesting, really! - but for now it's enough.

I have fewer leads by the minute. Ideas? What could that be and how to make the font fall-back nicely?

Example from Jeff's Coding Horror, note missing ff in Jeff, or ti in Meetings

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Resolution is fairly easy, if you have other Ubuntu computer where all displays properly.

I had Calibri Regular on my system. At work, I noticed, that all sites that were missing ligatures when looked at at home, are displayed properly. I took a look with fc-match what is used there to display Calibri, and sure enough, it was DejaVu Sans. So, at home, I've deleted the Calibri Regular font (DejaVu Sans was second in fall-back stack) and voila:

No missing ligatures

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.