Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual monitor setup, with the basic TwinView settings from my Nvidia-card (550 Ti). One monitor is my primary display (1600x900) and the other is my TV (1920*1080).

I have arranged XBMC to start up on my TV (using windowed mode, a quick and dirty GTKhack to hide the borders, and wmctrl to stretch it). This works for most games that have window mode as well (e.g. Shank2). However, I am unable to get some others working as I am unable to select the 1920x1080 resolution in their settings menu. All available resolutions for my primary display and the combined resolution are available. (e.g. Vessel, Snapshot)

How is it possible to provide my 1920x1080 resolution to the applications/games?

Every other workaround/solution is also very much appreciated!

share|improve this question
add comment

2 Answers 2

What you're trying to do is not possible with TwinView.

TwinView works by adding a fake display mode with the combined resolution to the primary display. For example, if you have two 1024x768 monitors, the driver tells the OS that there is only one screen with the resolutions of the primary display and an additional, fake 2048x768 mode. When you select this mode, the OS thinks it has a single 2048x768 screen, and the driver takes care of sending portions of the image to the correct displays. This means you don't need any special support from applications, but you also e.g. can't fullscreen an application only on one of the displays - the apps will all think there is only a single 2048x768 display.

The solution is to disable TwinView and use a driver which has XRandR support. This is present in the Nvidia driver since version 302. Use Ubuntu's Displays panel to configure the displays through XRandR (in 12.04 and later, click on the power button in the top right and select "Displays...").

share|improve this answer
add comment

At settings in Displays you select the red screen which is TwinView and change on buttom to off at the box next to your laptop screen. Then Apply a box will appear which you will need to press keep settings. Now you shut see it only on the tv and your TwinView shut come black. Displays Settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.