Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 12.04 on my UEFI ASUS laptop. Upon my first boot I am presented with a terminal instead of the GUI. I get a no screens found error if attempting to use startx. I am using an AMD Radeon HD 7730M with a Radeon HD 7660G switchable graphics configuration. How do I fix no screens error?

I have followed the instructions on this page How to turn off ATI Radeon HD 7730M (on Dell inspiron 7520)? in order to load the driver for my GPU and have the same result.

After completing installation I attempt to verify using the following command:

fglrxinfo

I get Error: unable to open display (null).

share|improve this question
    
Welcome to Ask Ubuntu! What have you tried? Using the search I find a lot of relevant questions. For example, does the following help you? Why my live installation results blank screen? (also Asus/UEFI) –  gertvdijk Feb 5 '13 at 21:46
    
Problem solved: youtube.com/watch?v=ReyT56rTWnA –  Ryan Feb 6 '13 at 5:29
    
@Ryan Please add your solution as an answer so that others may benefit from your experience! –  Elder Geek Jun 13 at 15:28

1 Answer 1

Open a terminal and issue the command:

sudo lspci|grep VGA

write down the first entries address xx:xx.x on the left (where xx:xx.x is the numbers displayed)

then issue the commands

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak (to back up your current config)

sudo nvidia-xconfig

sudo gedit /det/X11/xorg.conf (to edit configuration)

Move down to the Device section.

Just before the end section add BusID "PCI:XX:XX.X" Where XX:XX.X is your cards address you wrote down earlier.

Save the file, exit and reboot

Source: Ryan solution from comments with minor mods for backup and clarity

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.