Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problems with facebook and gmail only: It works fine and lets me log in, view the content, read new messages, etc. But after 5-10 minutes it doesn't load at all:

This webpage is not available.

The webpage at http://www.facebook.com/ might be temporarily down or it may have moved permanently to a new web address.

More information on this error Below is the original error message

Error 101 (net::ERR_CONNECTION_RESET):
Unknown error

After deleting cookies this problem disappears for 5-10 minutes, then I get the same error. It happens with Google Chrome and Firefox. Ping works fine.

I have checked System → Preferences → Network Proxy, it's set to the default: "Direct Internet Connection". Then I ran the test at chrome://net-internals/#tests and got some "FAIL" results

  • Use system proxy settings
  • Disable IPv6 host resolving
  • Probe for IPv6 host resolving

IPv6 is disabled.

share|improve this question
    
@Julia, how do you connect to the internet? Is there a proxy server involved, or some kind of content-filtering or session-aware firewall? –  Mike Feb 7 '11 at 17:57
2  
Also, a Google employee (in a thread at google.com/support/forum/p/Chrome/…) recommends that you navigate to “chrome://net-internals/#tests”, and enter the address you're having trouble with to get some diagnostics. (Wait until you are having the problem to run the tests.) Please edit your question to include this information, and hopefully someone will be able to help you. –  Mike Feb 7 '11 at 18:05
1  
Do other sites work when you cant access FB or Gmail? Where is this error message shown? FF usually shows "Server server.tld is responding too slowly",etc Are you using an proxy? –  papukaija Feb 12 '11 at 14:43
1  
Can you copy'n'paste output of ifconfig? –  Olli Feb 13 '11 at 12:58
1  
papukaija, other sites works normal, without any problems or disfuntions. I've turned off all proxies. –  user10791 Feb 14 '11 at 0:56

2 Answers 2

Some troubleshooting ideas :

Start a terminal and run watch -d -n 20 dig www.facebook.com. Then, the moment that gmail or facebook shows the error, ALT-TAB to your terminal window and watch the next update for any changes. I'm guessing that these sites have load balancers in place that are changing the IP addresses behind the scenes. It's possible that your ISP is caching the content without your knowledge and your cookie is becoming invalid because the content being provided by your ISP is no longer a match for the connection being made by your browser.

watch -d -n 20 dig www.facebook.com

You might be able to circumvent this by changing your DNS servers. Try right clicking on nm-applet, then choose "Edit Connections". Choose your ethernet connection (probably "auto eth0"), then "Edit". Go to the IPv4 settings and change "Automatic DHCP" to "Automatic DHCP (addresses only)".

Editing auto eth0

All your going to change is the DNS entries - either use Google's entries (enter 8.8.8.8, 4.4.4.4), or OpenDNS (enter 208.67.222.222, 208.67.220.220)

I suppose the other option for possibly circumventing such a time-out is to run Gmail over https. Not sure if Facebook supports fully encrypted sessions. To set Gmail to use https, go to your account settings at the top-right of the page, then in the General tab, find the "Use HTTPS" option and select it.

Gmail Settings

share|improve this answer

I had a similar problem with Firefox. Even though I had IPV6 disabled on the system, I still had to disable it within Firefox.

I went to About:Config Entered IPV6 as the search term. Changed value for network.dns.disableIPv6 from false to true

I don't know if it will help you, but that worked for me.

share|improve this answer
    
That's not future-proof though, the way IPv4 is heading... –  Nathan Osman Feb 18 '11 at 18:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.