Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Evidently, in earlier releases of Ubuntu, an animation add-on plugin for Compiz called Skewer could be tweaked to get a slide-in/slide-out effect for opening and closing Windows. Alas, I discovered Guake while running Quantal, and Skewer is gone from the Compiz plugin packages provided in the official repos. Guake's really nice, but the fade/expand effect just feels wrong -- is there any way to get Skewer back, or is there some other plugin that'll do what I want?

share|improve this question

1 Answer 1

I found a great article about this in Fedora Forum:

http://forums.fedoraforum.org/showthread.php?t=197409

Basically you do the following:

sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-fusion-plugins-extra

Launch Compiz Configuration Settings Manager (CCSM), go to the Effects section, tick the box next to Animations Add-On, then click on Animations.

In Animations; under Animation Selection; for the Open Animation tab; click on New, then:

  • Select Burn as your Open Effect
  • Enter 900 for Duration
  • Enter (type=Normal) & name=guake for Window Match
  • Enter fire_life=0.1, fire_particles=100, fire_size=0.1, fire_slowdown=0.1, fire_direction=1 in Options
  • Click on Close

Move this item up to the second position with the Up button, then click on the first item in the Animation Selection list (which should be a catch-all Glide 2 effect with certain exemptions), click Edit and add the exemption &!(name=guake) to the end of its Window Match entry.

Repeat this process for the Close Animation tab and you should then be all set!

Launch Guake and you should see it slide down from the Unity Panel at the top of the screen.

If like me, you find that this effect does not persist correctly over reboot and you end up with the default Burn effect (Guake appearing and disappearing in a burst of big flames) then just go back into CCSM, click on the Animations Add-On button, select Burn and set everything down to its lowest, selecting up for Fire direction. This will set the global defaults for Burn.

I hope this helps anyone. ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.