Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am using windows 7 on dell dual core. i have recently installed ubuntu 12.04 on VB4.2.6. but the speed is very slow at doing everything. opening terminal etc. any way to improve that? thanks in advance

share|improve this question
    
possible duplicate of Why is my perfomance too bad in Virtual Box? –  Braiam Nov 29 '13 at 2:02

3 Answers 3

To speed up any VM, you can:

  1. Enable Hardware virtualization and Nested Paging: VM settings -> System -> Acceleration tab. For this to work you have to make sure that your CPU supports Intel VT-x for Intel processors or AMD-v for AMD processors and that it is turned on in BIOS;
  2. Enable 3d Acceleration: VM Settings -> Display -> Video tab;
  3. Allocate to the VM that much memory and run that many programs on Host together with VM, that your Host OS has enough free RAM left;
  4. The above were primary recommendations that really make a difference and are easily achievable, however there are a lot of other ways to improve performance of virtual machines to a different extent. Here are some examples:
    • put your VM on a separate hard drive to improve I/O (can be a major performance gain, but requires a separate hard drive);
    • disable all the unneeded services/programs/visual effects on Guest;
    • if your Host/Guest filesystem supports defragmentation - use it. There are also tools that can try to defragment a specific file (virtual disk image in our case);
    • install Guest Additions;
    • if you have enough RAM you can disable swap file/partition on Host completely or tune it in a way that it is used only when a large portion of RAM (like 90%) is used.
    • exclude virtual disk images of your virtual machines from Antivirus checklist
    • and so on.

For a comprehensive list of approaches to increase VM performance, have a look at this article http://www.hanselman.com/blog/VMPerformanceChecklistBeforeYouComplainThatYourVirtualMachineIsSlow.aspx

share|improve this answer

The other answer is good, but the link with more information seems Microsoft-centric.

This link http://blog.jdpfu.com/2012/09/14/solution-for-slow-ubuntu-in-virtualbox has a Win7 host, Ubuntu Guest solution for VirtualBox with specific VirtualBox settings. It is about running Ubuntu Guests too:

Disk I/O - virtIO, if possible; SATA if no other choice

  • Allocate the minimal CPU and RAM for the guest workload
  • Network I/O - virtIO, if possible; Intel PRO/1000 if no other choice
  • Keep disk storage allocations as small as possible.
  • Use pre-allocated storage files on spinning disks; avoid sparc files. If you have SSD, use whatever storage you like - even QCOW2 with compression
  • Turn down the graphics "cheese" - No 2D or 3D extensions, at least not initially. Unity and Gnome3 suck graphics. Try them after you have a highly responsive system working with a simple GUI.
  • Never over-allocate RAM or CPU. Sharing.
  • 1 CPU is usually enough for most guests, even if you have 6, more than 2 CPUs per guest just isn't necessary, even for an email server for 50 people.
  • Leave 1G of RAM for the hostOS and 1 CPU for the hostOS, if you can.

Anyway, hope this helps.

BTW, How do I improve the performance of my VirtualBox guest? is a similar question with slightly different information.

share|improve this answer

Having very slow perform when running Ubuntu 12.10 and 13.04 in virtualbox? It’s because Ubuntu can’t use graphics card for acceleration, ubuntu uses CPU for rendering graphics trough LLVMpipe. It makes running ubuntu in virualbox really slow.

To check if your Ubuntu 12.10 or 13.04 guest is using 3D acceleration

/usr/lib/nux/unity_support_test -p

You should see something like this

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes
Unity 3D supported: no

If you see “Not software rendered” and “Unity 3D supported” both say no. This means Unity is using slow LLVMpipe.

To enable 3D supported, fist you will need to update linux-headers

uname -r
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get autoremove
sudo apt-get install build-essential

Now insert vitualbox guest iso from devices and to install manually

cd /media
ls
cd username
ls
cd VBOX*
ls
sudo ./VBoxLinuxAdditions.run

Insert vboxvideo to /etc/modules

sudo nano /etc/modules

Add “vboxvideo” at the end of the file

loop
lp
vboxvideo

Reboot the machine

sudo reboot

Source: http://namhuy.net/951/how-to-fix-slow-performance-ubuntu-13-04-running-in-virtualbox.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.