Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everytime I am trying to install a package with apt-get install I get this.

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 deluge-gtk : Depends: python-notify but it is not going to be installed
 fontconfig : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 gstreamer0.10-plugins-good:i386 : Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
                                   Depends: libflac8:i386 (>= 1.2.1) but it is not going to be installed
 ia32-libs-multiarch:i386 : Depends: libasyncns0:i386 but it is not going to be installed
                            Depends: libfontconfig1:i386 but it is not going to be installed
                            Depends: libsdl-mixer1.2:i386 but it is not going to be installed
                            Depends: libsdl-image1.2:i386 but it is not going to be installed
                            Depends: libsdl-ttf2.0-0:i386 but it is not going to be installed
                            Depends: libsdl1.2debian:i386 but it is not going to be installed
 indicator-application : Depends: libdbusmenu-gtk3-4 (>= 0.4.2) but it is not going to be installed
 libappindicator1 : Depends: libdbusmenu-glib4 (>= 0.4.2) but it is not going to be installed
                    Depends: libdbusmenu-gtk4 (>= 0.4.2) but it is not going to be installed
 libappindicator3-1 : Depends: libdbusmenu-glib4 (>= 0.4.2) but it is not going to be installed
                      Depends: libdbusmenu-gtk3-4 (>= 0.4.2) but it is not going to be installed
 libasound2-plugins:i386 : Depends: libpulse0:i386 (>= 1:0.99.1) but it is not going to be installed
 libblas3 : Depends: libgfortran3 (>= 4.3) but it is not going to be installed
 libcairo2 : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libcairo2:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 libcanberra-gtk0:i386 : Depends: libcanberra0:i386 (>= 0.12) but it is not going to be installed
 libcanberra-gtk3-module : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not going to be installed
 libgd2-xpm : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libgd2-xpm:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 libgettextpo0:i386 : Depends: libcroco3:i386 (>= 0.6.2) but it is not going to be installed
 libgtk-3-0 : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libgtk2.0-0 : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libgtk2.0-0:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 liblapack3 : Depends: libgfortran3 (>= 4.6) but it is not going to be installed
              Breaks: liblapack3gf (< 3.4.1-1)
 liblapack3gf : Depends: libgfortran3 (>= 4.6) but it is not going to be installed
 libpango1.0-0 : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libpango1.0-0:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 libpulse-mainloop-glib0:i386 : Depends: libpulse0:i386 (>= 1:1.1-0ubuntu15.2) but it is not going to be installed
 libpulsedsp:i386 : Depends: libpulse0:i386 (>= 1:1.1-0ubuntu15.2) but it is not going to be installed
 libqtgui4:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 librsvg2-common : Depends: librsvg2-2 (= 2.36.1-0ubuntu1) but it is not going to be installed
 librsvg2-common:i386 : Depends: librsvg2-2:i386 (= 2.36.1-0ubuntu1) but it is not going to be installed
 libsdl-net1.2:i386 : Depends: libsdl1.2debian:i386 (>= 1.2.10-1) but it is not going to be installed
 libxft2 : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
 libxft2:i386 : Depends: libfontconfig1:i386 (>= 2.8.0) but it is not going to be installed
 notification-daemon : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not going to be installed
 openssh-client : Depends: libedit2 (>= 2.11-20080614-1) but it is not going to be installed
 php5-cli : Depends: libedit2 (>= 2.11-20080614-1) but it is not going to be installed
 postgresql-client-9.1 : Depends: libedit2 (>= 2.11-20080614-1) but it is not going to be installed
 python-glade2 : Depends: libglade2-0 (>= 1:2.6.1) but it is not going to be installed
 python-pygame : Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
                 Depends: libsdl-mixer1.2 but it is not going to be installed
                 Depends: libsdl-ttf2.0-0 but it is not going to be installed
                 Depends: libsdl1.2debian (>= 1.2.10-1) but it is not going to be installed
                 Depends: libsmpeg0 but it is not going to be installed
 rtorrent : Depends: libtorrent14 but it is not going to be installed
 x11-utils : Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

When i run apt-get -f install I get this.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  bluez-alsa:i386 libgconf-2-4:i386 libatk1.0-0:i386 libqt4-declarative:i386 libgail18:i386 libqt4-qt3support:i386
  libunistring0:i386 libcupsimage2:i386 gtk2-engines:i386 libgudev-1.0-0:i386 libcdparanoia0:i386 libcairo-gobject2:i386
  libavc1394-0:i386 ssh-import-id libqt4-test:i386 libqt4-script:i386 libqt4-designer:i386 libqt4-network:i386
  libqt4-dbus:i386 libproxy1:i386 ibus-gtk:i386 libdbus-glib-1-2:i386 libspeex1:i386 gvfs-libs:i386 libgomp1:i386
  libcapi20-3:i386 libibus-1.0-0:i386 libcairo2:i386 libvisual-0.4-0:i386 libcanberra-gtk-module:i386
  gtk2-engines-murrine:i386 libwavpack1:i386 libqt4-opengl:i386 libsoup-gnome2.4-1:i386 libglib2.0-0:i386
  libmysqlclient18:i386 gstreamer0.10-plugins-good:i386 libqt4-xmlpatterns:i386 librsvg2-common:i386 libdatrie1:i386
  libiec61883-0:i386 libgdk-pixbuf2.0-0:i386 libpixman-1-0:i386 libqtcore4:i386 libtheora0:i386 libaa1:i386 libthai0:i386
  libao4:i386 libcanberra-gtk0:i386 libqt4-sql:i386 libqt4-svg:i386 libgail-common:i386 liborc-0.4-0:i386
  libraw1394-11:i386 libshout3:i386 libdv4:i386 libqt4-xml:i386 gstreamer0.10-x:i386 libgettextpo0:i386 libsdl-net1.2:i386
  libjasper1:i386 libvisual-0.4-plugins:i386 libgstreamer-plugins-base0.10-0:i386 libudev0:i386 libgnome-keyring0:i386
  gtk2-engines-pixbuf:i386 libqtgui4:i386 libtag1c2a:i386 libssl0.9.8:i386 gtk2-engines-oxygen:i386 libpango1.0-0:i386
  gvfs:i386 libqt4-sql-mysql:i386 libqt4-scripttools:i386 libqtwebkit4:i386 libgstreamer0.10-0:i386 libxcb-shm0:i386
  gstreamer0.10-plugins-base:i386 libmng1:i386 libgtk2.0-0:i386 glib-networking:i386 libsoup2.4-1:i386 libtag1-vanilla:i386
  libjson-glib-1.0-0 librsvg2-2:i386 libavcodec53:i386 libcroco3:i386 libgsm1:i386 libsdl-mixer1.2:i386 libavutil51:i386
  libsdl-ttf2.0-0:i386 libsdl-image1.2:i386 libcanberra0:i386 gstreamer0.10-gconf:i386 libmad0:i386 libmikmod2:i386
  libmp3lame0:i386 libopenjpeg2:i386 libvpx1:i386 libdirac-encoder0:i386 libschroedinger-1.0-0:i386 libxvidcore4:i386
  libx264-123:i386 libva1:i386 libwebp2:i386 libqtdbus4:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  colord freeglut3:i386 gstreamer0.10-gconf:i386 gtk2-engines-pixbuf:i386 ia32-libs ia32-libs-i386:i386 lesstif2:i386
  libapache2-mod-php5 libappindicator1 libasyncns0 libasyncns0:i386 libavcodec53:i386 libavutil51:i386 libcaca0
  libcaca0:i386 libcairo2 libcairo2:i386 libcanberra-gtk3-0 libcanberra0 libcanberra0:i386 libcolord1 libcroco3
  libcroco3:i386 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdirac-encoder0:i386 libdirectfb-1.2-9
  libdirectfb-1.2-9:i386 libedit2 libedit2:i386 libexif12 libexif12:i386 libflac8 libflac8:i386 libfltk1.1:i386
  libfontconfig1 libfontconfig1:i386 libgail-common:i386 libgail18:i386 libgd2-xpm libgd2-xpm:i386 libgfortran3 libglade2-0
  libgnutls26 libgnutls26:i386 libgphoto2-2 libgphoto2-2:i386 libgphoto2-port0 libgphoto2-port0:i386 libgsm1:i386
  libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-0:i386 libgusb2 libieee1284-3 libjbig0 libjbig0:i386
  libjpeg62 libjpeg62:i386 libjson-glib-1.0-0 libjson0 libjson0:i386 liblapack3gf liblcms2-2 liblzma5 liblzma5:i386
  liblzo2-2:i386 libmad0 libmad0:i386 libmikmod2 libmikmod2:i386 libmp3lame0 libmp3lame0:i386 libnotify4 libnspr4
  libnspr4:i386 libnspr4-0d:i386 libnss3 libnss3:i386 libnss3-1d libnss3-1d:i386 libonig2 libopenjpeg2:i386 libpam0g
  libpam0g:i386 libpango1.0-0 libpango1.0-0:i386 libpopt0 libpopt0:i386 libpulse0 libpulse0:i386 libqdbm14 libqt4-dbus
  libqt4-dbus:i386 libqt4-declarative:i386 libqt4-designer:i386 libqt4-network:i386 libqt4-opengl:i386
  libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386 libqt4-sql-mysql:i386 libqt4-svg:i386
  libqt4-test:i386 libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4 libqtcore4:i386 libqtdbus4 libqtdbus4:i386
  libqtgui4:i386 librsvg2-2 librsvg2-2:i386 librsvg2-common librsvg2-common:i386 libsane libsane:i386 libsane-common
  libsane-extras libsane-extras:i386 libsane-extras-common libschroedinger-1.0-0:i386 libsdl-image1.2 libsdl-image1.2:i386
  libsdl-mixer1.2 libsdl-mixer1.2:i386 libsdl-ttf2.0-0 libsdl-ttf2.0-0:i386 libsdl1.2debian libsdl1.2debian:i386
  libsigc++-2.0-0c2a libsigc++-2.0-0c2a:i386 libsmpeg0 libsndfile1 libsndfile1:i386 libssh2-1:i386 libsvga1:i386
  libsysfs2:i386 libtiff4 libtiff4:i386 libts-0.0-0 libts-0.0-0:i386 libv4l-0 libv4l-0:i386 libv4lconvert0
  libv4lconvert0:i386 libva1:i386 libvpx1:i386 libwebp2 libwebp2:i386 libx264-123:i386 libx86-1:i386
  libxcb-render-util0:i386 libxft2 libxft2:i386 libxml2 libxml2:i386 libxml2-dev libxmuu1 libxmuu1:i386 libxvidcore4:i386
  openssh-blacklist openssh-blacklist-extra openssh-client openssh-server php5-cgi php5-cli php5-common php5-curl php5-gd
  php5-imap php5-mcrypt php5-mysql php5-sqlite php5-xsl plymouth python-appindicator python-glade2 python-gtk2
  python-notify qdbus sane-utils
Suggested packages:
  ia32-libs-gtk ia32-libs-gtk-i386:i386 php-pear libcanberra-gtk0 libcanberra-pulse libcanberra-pulse:i386 libgd-tools
  libgd-tools:i386 gphoto2 gphoto2:i386 gtkam gtkam:i386 liblcms2-utils libpam-doc libpam-doc:i386 ttf-baekmuk
  ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp ttf-baekmuk:i386 ttf-arphic-gbsn00lp:i386
  ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386 pulseaudio pulseaudio:i386
  libqt4-declarative-folderlistmodel:i386 libqt4-declarative-gestures:i386 libqt4-declarative-particles:i386
  libqt4-declarative-shaders:i386 qt4-qmlviewer:i386 libqt4-dev:i386 libicu48:i386 qt4-qtconfig:i386 librsvg2-bin
  librsvg2-bin:i386 hpoj hplip hpoj:i386 hplip:i386 ssh-askpass libpam-ssh keychain monkeysphere rssh molly-guard
  desktop-base plymouth-drm python-gtk2-doc unpaper
Recommended packages:
  sane-utils:i386 xml-core:i386 ncurses-term
The following packages will be REMOVED:
  ia32-libs-multiarch:i386 libpulse-mainloop-glib0:i386 libpulsedsp:i386
The following NEW packages will be installed:
  colord freeglut3:i386 gstreamer0.10-gconf:i386 ia32-libs-i386:i386 lesstif2:i386 libasyncns0 libasyncns0:i386
  libavcodec53:i386 libavutil51:i386 libcaca0 libcaca0:i386 libcanberra-gtk3-0 libcanberra0 libcanberra0:i386 libcolord1
  libcroco3 libcroco3:i386 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdirac-encoder0:i386 libdirectfb-1.2-9
  libdirectfb-1.2-9:i386 libedit2 libedit2:i386 libexif12 libflac8 libflac8:i386 libfltk1.1:i386 libfontconfig1
  libfontconfig1:i386 libgfortran3 libglade2-0 libgphoto2-2 libgphoto2-port0 libgsm1:i386 libgusb2 libieee1284-3 libjbig0
  libjbig0:i386 libjpeg62:i386 libjson-glib-1.0-0 libjson0 libjson0:i386 liblcms2-2 liblzma5:i386 liblzo2-2:i386 libmad0
  libmad0:i386 libmikmod2 libmikmod2:i386 libmp3lame0:i386 libnotify4 libnspr4-0d:i386 libnss3-1d:i386 libonig2
  libopenjpeg2:i386 libpam0g:i386 libpopt0:i386 libpulse0 libpulse0:i386 libqdbm14 libqtdbus4 libqtdbus4:i386 librsvg2-2
  librsvg2-2:i386 libsane libsane-extras libsane-extras:i386 libsane-extras-common libschroedinger-1.0-0:i386
  libsdl-image1.2 libsdl-image1.2:i386 libsdl-mixer1.2 libsdl-mixer1.2:i386 libsdl-ttf2.0-0 libsdl-ttf2.0-0:i386
  libsdl1.2debian libsdl1.2debian:i386 libsigc++-2.0-0c2a:i386 libsmpeg0 libsndfile1 libsndfile1:i386 libssh2-1:i386
  libsvga1:i386 libsysfs2:i386 libts-0.0-0 libts-0.0-0:i386 libv4l-0 libv4lconvert0 libva1:i386 libvpx1:i386 libwebp2
  libwebp2:i386 libx264-123:i386 libx86-1:i386 libxcb-render-util0:i386 libxmuu1:i386 libxvidcore4:i386 openssh-blacklist
  openssh-blacklist-extra python-notify sane-utils
The following packages will be upgraded:
  gtk2-engines-pixbuf:i386 ia32-libs libapache2-mod-php5 libappindicator1 libcairo2 libcairo2:i386 libexif12:i386
  libgail-common:i386 libgail18:i386 libgd2-xpm libgd2-xpm:i386 libgnutls26 libgnutls26:i386 libgphoto2-2:i386
  libgphoto2-port0:i386 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0 libgtk2.0-0:i386 libjpeg62 liblapack3gf
  liblzma5 libmp3lame0 libnspr4 libnspr4:i386 libnss3 libnss3:i386 libnss3-1d libpam0g libpango1.0-0 libpango1.0-0:i386
  libpopt0 libqt4-dbus libqt4-dbus:i386 libqt4-declarative:i386 libqt4-designer:i386 libqt4-network:i386 libqt4-opengl:i386
  libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386 libqt4-sql-mysql:i386 libqt4-svg:i386
  libqt4-test:i386 libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4 libqtcore4:i386 libqtgui4:i386
  librsvg2-common librsvg2-common:i386 libsane:i386 libsane-common libsigc++-2.0-0c2a libtiff4 libtiff4:i386 libv4l-0:i386
  libv4lconvert0:i386 libxft2 libxft2:i386 libxml2 libxml2:i386 libxml2-dev libxmuu1 openssh-client openssh-server php5-cgi
  php5-cli php5-common php5-curl php5-gd php5-imap php5-mcrypt php5-mysql php5-sqlite php5-xsl plymouth python-appindicator
  python-glade2 python-gtk2 qdbus
84 upgraded, 103 newly installed, 3 to remove and 733 not upgraded.
4 not fully installed or removed.
Need to get 0 B/86.9 MB of archives.
After this operation, 97.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 123953 files and directories currently installed.)
Unpacking freeglut3:i386 (from .../freeglut3_2.6.0-4_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/freeglut3_2.6.0-4_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libglut.so.3.9.0.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libglut.so.3.9.0'): Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking lesstif2:i386 (from .../lesstif2_1%3a0.95.2-1.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/lesstif2_1%3a0.95.2-1.1_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libXm.so.2.0.1.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libXm.so.2.0.1'): Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libasyncns0:i386 (from .../libasyncns0_0.8-4_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libasyncns0_0.8-4_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libasyncns.so.0.3.1.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libasyncns.so.0.3.1'): Permission denied
No apport report written because MaxReports is reached already
                                                              Unpacking libts-0.0-0:i386 (from .../libts-0.0-0_1.0-11_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.0-11_i386.deb (--unpack):
 error creating directory `./usr/lib/i386-linux-gnu/ts0': Permission denied
No apport report written because MaxReports is reached already
                                                              Unpacking libdirectfb-1.2-9:i386 (from .../libdirectfb-1.2-9_1.2.10.0-5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libdirectfb-1.2-9_1.2.10.0-5_i386.deb (--unpack):
 error creating directory `./usr/lib/i386-linux-gnu/directfb-1.2-9': Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libedit2:i386 (from .../libedit2_2.11-20080614-5_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libedit2_2.11-20080614-5_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libedit.so.2.11.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libedit.so.2.11'): Permission denied
No apport report written because MaxReports is reached already
                                                              Preparing to replace libexif12:i386 0.6.20-2ubuntu0.1 (using .../libexif12_0.6.20-3_i386.deb) ...
Unpacking replacement libexif12:i386 ...
dpkg: error processing /var/cache/apt/archives/libexif12_0.6.20-3_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libexif.so.12.3.2.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libexif.so.12.3.2'): Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libflac8:i386 (from .../libflac8_1.2.1-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libflac8_1.2.1-6_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libFLAC.so.8.2.0.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libFLAC.so.8.2.0'): Permission denied
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
No apport report written because MaxReports is reached already
                                                              Unpacking libfontconfig1:i386 (from .../libfontconfig1_2.9.0-7.1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libfontconfig1_2.9.0-7.1_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libfontconfig.so.1.5.0.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libfontconfig.so.1.5.0'): Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libfontconfig1 (from .../libfontconfig1_2.9.0-7.1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libfontconfig1_2.9.0-7.1_amd64.deb (--unpack):
 unable to create `/usr/lib/x86_64-linux-gnu/libfontconfig.so.1.5.0.dpkg-new' (while processing `./usr/lib/x86_64-linux-gnu/libfontconfig.so.1.5.0'): Permission denied
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to replace libxft2:i386 2.2.0-3ubuntu2 (using .../libxft2_2.3.1-1_i386.deb) ...
De-configuring libxft2 ...
Unpacking replacement libxft2:i386 ...
dpkg: error processing /var/cache/apt/archives/libxft2_2.3.1-1_i386.deb (--unpack):
 unable to create `/usr/lib/i386-linux-gnu/libXft.so.2.3.1.dpkg-new' (while processing `./usr/lib/i386-linux-gnu/libXft.so.2.3.1'): Permission denied
No apport report written because MaxReports is reached already
                                                              Preparing to replace libxft2 2.2.0-3ubuntu2 (using .../libxft2_2.3.1-1_amd64.deb) ...
De-configuring libxft2:i386 ...
Unpacking replacement libxft2 ...
dpkg: error processing /var/cache/apt/archives/libxft2_2.3.1-1_amd64.deb (--unpack):
 unable to create `/usr/lib/x86_64-linux-gnu/libXft.so.2.3.1.dpkg-new' (while processing `./usr/lib/x86_64-linux-gnu/libXft.so.2.3.1'): Permission denied
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 /var/cache/apt/archives/freeglut3_2.6.0-4_i386.deb
 /var/cache/apt/archives/lesstif2_1%3a0.95.2-1.1_i386.deb
 /var/cache/apt/archives/libasyncns0_0.8-4_i386.deb
 /var/cache/apt/archives/libts-0.0-0_1.0-11_i386.deb
 /var/cache/apt/archives/libdirectfb-1.2-9_1.2.10.0-5_i386.deb
 /var/cache/apt/archives/libedit2_2.11-20080614-5_i386.deb
 /var/cache/apt/archives/libexif12_0.6.20-3_i386.deb
 /var/cache/apt/archives/libflac8_1.2.1-6_i386.deb
 /var/cache/apt/archives/libfontconfig1_2.9.0-7.1_i386.deb
 /var/cache/apt/archives/libfontconfig1_2.9.0-7.1_amd64.deb
 /var/cache/apt/archives/libxft2_2.3.1-1_i386.deb
 /var/cache/apt/archives/libxft2_2.3.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have already tried out these solutions: askubuntu.com/questions/106854/apt-get-install-error

Cannot install anything through Terminal - apt-get -f install

apt-get upgrade fails due to dependency issues

I use Linux version 3.2.0-35-generic (buildd@allspice) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/md2 during installation
UUID=9454a058-f582-418b-bbb0-c52a14b2636f /               ext4    errors=remount-ro,usrquota 0       1
# /boot was on /dev/md0 during installation
UUID=f3f8ddcc-9906-4896-b9de-beb21689f37e /boot           ext2    defaults        0       2
# swap was on /dev/md1 during installation
UUID=d5f380b3-eca3-40ad-9b14-b29d7d603dd8 none            swap    sw              0       0

i was trying to install deluge when this happened and my server edition

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

here is mount

india262:~# mount
/dev/md2 on / type ext4 (rw,errors=remount-ro,usrquota)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/md0 on /boot type ext2 (rw)
share|improve this question
    
Welcome to Ask Ubuntu! Could you include the output of apt-cache policy (no further options) in your question? However, I think something has damaged severely... looking at the Permission denied errors. I've never seen this before. Some other obvious thoughts: any disk full? (df -h) Mount point read-only? grep ro /proc/mounts. And you run this with sudo, right? –  gertvdijk Feb 5 '13 at 15:23
1  
It appears to be trying to fix, but you are getting permission denied as gertvdijk mentions and you are not showing the full command you are using. Are you using sudo apt-get -f install? –  zoopster Feb 5 '13 at 15:35
    
yes i run with sudo. The disk is not full. –  Λευτέρης Τσεργούλας Feb 5 '13 at 15:50
1  
Is /var on a separate partition and is it mounted noexec? –  bodhi.zazen Feb 5 '13 at 17:25
    
how can i check that out? –  Λευτέρης Τσεργούλας Feb 6 '13 at 8:40

1 Answer 1

The .deb packages in /var/cache/apt/archives are used by the system to install software. But once the software is installed, these .deb packages are no longer needed.

first try:

sudo apt-get clean

then:

sudo apt-get -f install

share|improve this answer
    
Why would removing locally cached packages solve these errors? I don't see it. –  gertvdijk Feb 5 '13 at 15:26
    
first, these packages are removed with their permissions.second, you will reinstall the necessary packages with the right permission.the installers will use these packages with the proper permission.third, unnecessary packages are flushed away. –  1linecode Feb 5 '13 at 15:35
    
same result. nothing happens. it shows me the same as above –  Λευτέρης Τσεργούλας Feb 5 '13 at 15:35
    
try sudo su then the commands. –  1linecode Feb 5 '13 at 15:37
    
@raminomrani You're wrong here. It won't remove any package from the system. It's just clearing the APT download cache. To extract the packages from the cache they're first checked for integrity. If they're damaged in some sort they won't be processed. And that su will not make a difference as sudo will already elevate privileges. –  gertvdijk Feb 5 '13 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.