Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to upgrade my old 10.10 to 12.04 using alternate CD, and had to upgrade to 11.04 first. Unfortunately I ran into the following error after upgrading and rebooting to ubuntu :

the disk drive for /boot is not yet ready or not present

.. with options to either ignore the error or manually repair.

Ignoring the error led to the same message with "/home" and them prompted the ubuntu log-in screen. Once logged, several errors messages popped up and no GUI was displayed, leaving no other option than to reboot.

Solutions for similar problems were given here : http://ubuntuforums.org/showthread.php?t=1724209 and there: Root filesystem check fails after power failure during installation installation (remount the root partition, then launch an update) but in my case that didn't fixed the issue.

My pc is configured as a dualboot windows7/ubuntu 64 bits on a Raid0, using two HD. My /etc/fstab is as following :

/dev/mapper/isw_djibifgbhd_Volume06 /     ext4 errors = remount-ro
/dev/mapper/isw_djibifgbhd_Volume03 /boot ext4 defaults
/dev/mapper/isw_djibifgbhd_Volume07 /home ext4 defaults
/dev/mapper/isw_djibifgbhd_Volume05 none  swap defaults

Using fsck -a and mount -a lead me to the following messages :

fsck -a :

fsck.ext4: No such file or directory while trying to open dev/mapper/isw_djibifgbhd_Volume06

mount -a :

mount: special device /dev/mapper/isw_djibifgbhd_Volume03 does not exist
mount: special device /dev/mapper/isw_djibifgbhd_Volume07 does not exist

When booting on a live CD, gparted could not recognized my partitions (just the two hard disks) while disk utility still detect how the different drives were configured.

I assume I just have to make the system recognize the volumes somehow. The solution may be trivial, but I am not used to deal with this kind of problems and I don't know how to resolve this issue.

If someone can give me some hints about how to proceed, thanks in advance !

share|improve this question

1 Answer 1

Solved there : http://ubuntuforums.org/showthread.php?p=12493772#post12493772

(names of the fakeraid partitions got edited somehow during the upgrade)

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Feb 5 '13 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.