Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Chrome 24.0.1312.68 which is supposed to have fixed a recent "can't load plug-in" error.

I have tried the instructions on the page to turn flash player on and I have restarted my browser and it still gives me this error. How do I get around this error?

share|improve this question
up vote 2 down vote accepted

Despite claims that the latest update has fixed things ...

The Stable channel has been updated to 24.0.1312.68 for Linux. This build contains the fix for Pepper Flash.

people may still be seeing the "can't load plug-in" error.

One workaround is to disable the Pepper Flash and use Adobe's if it's available. The Chrome browser will "see" the Adobe NPAPI Flash plug-in if it exists in ~/.mozilla/plugins.

For people who have installed Chromium as well, along with its goodies, the Flash plug-in will be in /usr/lib/flashplugin-installer/ So just copy it from there to ~/.mozilla/plugins.

In the long term, Adobe's policy is to not develop Flash for Linux anymore. And so the latest Flash will be the Pepper Flash which comes with Chrome. Unfortunately, it's still highly "experimental".

Edit: A way to still use Pepper Flash is described here:

  • Start Chrome
  • In chrome://plugins, enable Pepper Flash in case you disabled it (as suggested above)
  • Close the Chrome browser
  • Open a file manager and enable viewing of hidden files and folders (Ctrl+H)
  • Either delete the ~/.config/google-chrome/PepperFlash folder or rename it to something else.
  • Restart Chrome. Now Pepper Flash should work.

Further edit 20130208: Version 24.0.1312.69 worked out of the box for me and didn't need the "delete the ~/.config/google-chrome/PepperFlash folder" hack.

share|improve this answer
I am running 24.0.1312.68, I just upgraded it and still YouTube and thus flash refuses to work. – Brenton Horne Feb 5 '13 at 10:42
Google Chrome 24.0.1312.68 (Official Build 180326) OS Linux WebKit 537.17 (@140072) JavaScript V8 Flash User Agent Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.68 Safari/537.17 Command Line /opt/google/chrome/google-chrome --flag-switches-begin --flag-switches-end Executable Path /opt/google/chrome/google-chrome Profile Path /home/brentonhorne/.config/google-chrome/Default Variations 5666f941-fd526c81 – Brenton Horne Feb 5 '13 at 10:47
OK, so what does that mean to me? As far as fixing this? I must confess I know little if anything about programming & PCs in general just some basic terminal commands, what's good hardware wise, roughly and basic PC functions. – Brenton Horne Feb 5 '13 at 10:51
I've added an edit that allowed me to use Pepper Flash. Why don't you try it? – user25656 Feb 6 '13 at 5:02
Oh hey thanks, mate! – Brenton Horne Feb 6 '13 at 5:49

Go to chrome://plugins and set your setting like the following screenshot and refresh your page:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.